This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
OpenCPN Not Starting
Hi all,

Did a "sudo apt update && sudo apt full-ugrade" this morning. I noticed that OpenCPN upgraded.

Now it doesn't start. When I try to start it from a terminal, I get a lot of errors, mostly related to Alsa and Jack, but a few GTK and GL errors as well.

Anyone else having this problem?


Okay, I just confirmed it.

Running "sudo apt install opencpn=5.0.0-0~bionic1" to downgrade gives me an OpenCPN that starts, running "sudo apt install opencpn" gives an OpenCPN that fails.

So, if anyone else is having this problem, just downgrade and you'll get back a working version of OpenCPN.
I have just done apt dist-upgrade (AFAIK same as full-upgrade) and opencpn is the same version 5.0.0.
I am quite sure you have added the source for the beta repository of opencpn in the past and you have installed the new beta from there.
I don't think so, My sources.d/openplotter.list is
deb bionic main
deb buster main contrib non-free
deb bionic main
deb buster stable
deb stable main
deb buster main
deb-src buster main
deb buster main
deb buster main

Apt shows this: OpenCPN is coming form Is that correct?
pi@raspberrypi:/etc/apt/sources.list.d $ apt policy opencpn
Installed: 5.0.0-0~bionic1
Candidate: 5.0.0-20200428
Version table:
5.0.0-20200428 500
500 buster/main armhf Packages
*** 5.0.0-0~bionic1 500
500 bionic/main armhf Packages
100 /var/lib/dpkg/status
Okay, I think I'm starting to understand what happened. is being used for xygrib. It appears that a version of OpenCPN has been added to that repository.

How can I get apt to prefer one repository over another?
your sources for free-x are outdated
use them
deb debian main
ops you are right it is not the beta opencpn but the free-x repo. Actually we switched to to prevent this issue.

To get rid of old repositories used in pre-releses images you have just to press "add sources" in latest openplotter-settings app and they will be removed.
Hummm, did "add sources", or at least I thought I did! I manually removed the bad repo.

Forum Jump:

Users browsing this thread: 1 Guest(s)