This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Thread Rating:
  • 1 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
AvNav implementation in OP2
Martin is working on it.
Will ask him.
OK, let me know if you need anything
Hi, I've just used the "AvNav Updater" to update to this latest release, but I'm a bit confused about the status shown in the updater.

avnav-ocharts installed
avnav-oesenc invalid 4.2.17-2

or if i select to update the oesenc package than ocharts becomes invalid...
Here's a current list of plugin versions.

name state version candidate include
avnav-more-nmea-plugin installed 20210626
avnav-history-plugin installed 20210525
avnav-ocharts installed
avnav-update-plugin installed 20220124
avnav-ocharts-plugin installed 20220225-raspbian-buster
avnav installed 20220225
avnav-oesenc invalid 4.2.17-2
avnav-mapproxy-plugin installed 20220211

Is this expected?
yes, that's how it should be. there can be only one. either old avnav-oesenc ( for legacy charts) or new avnav-ocharts ( for old oesenc/oernc and new oesu)
I tried to explain it in the release notes
So simply ignore the oesenc or completely deinstall it.
If both are installed the new avnav-ocharts is used anyway.
I guess we will have a new update plugin soon that will ignore oesenc.
Thanks for both your replies.
On my raspPi4, I notice on taskmanager that AvNavOchartsProvider is sticking at 24% CPU Utilisation, RSS 379MB and VM 551MB even when I don't have AVNav displaying/moving charts any local/remote devices.

Looking on the AVNavOChartsProvider Status screen I notice the disk cache is constantly growing..

ChartSetBritish Isles 2022

716, minZoom=7, maxZoom=16
Version=2022-1, ValidTo=2023-01-11
1459/10000 (17009kb)
35879/400000, usedMemory=1414kb

Reading your release notes this time ;-) I see you say "However, major areas of the chart will be prerendered to cached tiles upon chart installation". Its been about 20hours since upgrading Pi, how long will this prerendering phase take and is there a way to determine % of prerendering progress?
FYI, that charts I have installed are the OESenc UK Chart.

Update: 2hours later I have checked again and cpu load has now dropped, AvNavOchartsProvider is at 0% cpu load.
You can always see the progress at the prefill row on the status page.
It shows you which set it is rendering and you see the chart numbers increasing.
It's just there to give you a smoother handling later. As it can at most consume around one CPU of the 4 available it should not really be a problem - and most of the time the Pi is idle anyway.
Unfortunately it will start over whenever you change settings.
But this process runs in the background - if you are showing a chart it will always prefer to work on your requests - and only continue the prefill if nothing else needs to be done.
Depending on the chart set sizes this really can take several (10+) hours.
In principle you cam limit the zoom level for the prefill (in the Server/Status page of AvNav at plugins you will find some settings for the ocharts plugin).
If you set this to e.g. 14 or 15 it will only render till this level and be much faster (with the cost of some potential delays later on when you are moving the chart).
Maybe you would like to play with this...
Hello, just found out that AvNav stopped showing AIS targets. 
To be more specific, i'm trying an "AIS simulator" at home, for development purposes, and I generate these paths:


OpenCPN and SignalK plugins like Freeboard-sk or VesselPositions show the target at the correct location, but AvNav does not show anything.
I've checked AIS is enabled in Settings > Layer, and that "Show class A" is checked in Settings > AIS.

I'm pretty sure the problem must be on my side, since last time I tested on a real environment it worked just fine, but it would be great to be able to see boats from a simulator.

BTW no errors or warnings on the log.


Just tested with the AIS simulator that comes with the Moitessier HAT app and after enabling debug mode, I found out that it is actually working (but filtered out because of distance), so definetly the problem is in my code sending the AIS values.
Anyway, I can't figure out how to send working AIS data from node-red, so any advise would be much appreciated! Smile
could you provide AIS stream from Port 10110?
nc <IP_of_SignalK> 10110 | grep AIVDM

Forum Jump:

Users browsing this thread: 1 Guest(s)