This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Thread Rating:
  • 1 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
AvNav implementation in OP2
That was absolutely right. I modified my node-red flow so the timestamp use ISO8601 date time strings (msg.timestamp = new Date(msg.timestamp).toISOString();) and now it works exactly as expected.

Thanks for your time,
New daily from today should also get the own MMSI from SK without the need of setting it in AvNav additionally.
Ok - the new release is there.
See the release notes - some of the features already have been discussed here.
A new installer is also there (mainly OP3).
It's me again with AIS questions Big Grin

So I just noticed that the AIS Info page that appears when I click on an AIS target doesn't show boath details like length or beam.
Also noticed that on the AIS settings configuration, the list of elements that i can select as First/Second/Third label is fixed, so I can't select length there either.
I don't know if that's just expected, a bug, or some misconfiguration on my side.

SignalK showing all the simulated boat data:

What I see in AvNav:

What I see in FreeboardSk (just to check):

Length and beam are currently not it the list.
Maybe you could create an issue on Github for that.
Done. I'll also take a look at the code on monday and see if I can contribute myself with a PR Smile
A PR would be great - but finally it needs implementation at several places...
Not to complex anyway.
Watching the AIS conversation I decided to update AVNAV. Whether it was that or something else I am not sure, but my raspberry pi is now going v.slowly and I can't do much (Which is a shame as I am sat on my boat trying to debug problem :-(

My setup is openplotter and avnav running from RaspPi4. 
To debug I vnc into the pi.   (Its going so slowly that the mouse pointer is taking seconds to move.. )

Looking at the task manager I can see that "AVNavOChartsProvider" is taking 24% of cpu and "python3" is taking 24% and "node" is taking 18%.
Total CPU usage 70%
Currently I can't use AVNav because the Pi is going to slowly its not loading and if/when its not updating data/screen etc.

Thinking there might be something wrong with charts I went into AVNAV -> AVNavChartProvider - ReloadCharts (Restart), however this results in an error - Unable to fetch ready state - Type Error. 

_ I am not sure if this is because Pi is going to slowly and causing this problem of if this is indicative of the problem
However the chart manager has "Ready status" CachePreFill is "Filling" Chartset status "Ready"

Another observation is on settings in OpenPlotter on chartplotter Apps the status Against AVNav Installer says "Open to apply and refresh". When I press open this message doesn't disappear.. 

sorry this isn't more descriptive. I'm not sure what to do
Sorry, please ignore my above message. I have figured out problem. 

I finally figured out what was wrong when i recognised that Total Server signalK throughput of 500 deltas/second was killing my raspberry pi performance.  I was then able to troubleshoot the problem down to having "Udp-nmea-sender" enabled
With this disabled my signalK paths is just 37, 18 of which are raspberry pi monitoring...

Sorry for 'noise' 

BTW: Ais is working, although it seems to think I am about to collide with myself as the status nav window is red. AIS D0.00nm, C0.00nm T00:00:00h Done. 

Any idea how it can ignore my own AIS
either take a look at
In Section AVNConfig exists options "ownMMSI"
or configure ownMMSI over WebConfigure

Forum Jump:

Users browsing this thread: 1 Guest(s)