This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
OpenPlotter - PyPilot - TinyPilot
#11
you just need to click the enable hardware uart button in openplotter serial settings and reboot.
Reply
#12
(2020-05-19, 12:23 AM)seandepagnier Wrote: you just need to click the enable hardware uart button in openplotter serial settings and reboot.

Thanks - found the button and yes that's a lot simpler but it still doesn't seem to work for me. So:
  • Pressed UART button to disable bluetooth etc
  • Rebooted RPi-4
  • Voltage divider which now supplies 3.3v from Arduino TX to PI-10 (GPIO15)
  • Direct connection between PI-8 (GPIO-14) and Arduino RX (so that's still 5v)
  • Installed Arduino IDE on RPI, it sees the /dev/ttyACM0 Serial Port now but when trying to upload any sketch: I get 10 errors:
avrdude: stk500)getsync() attempt x of 10: into in sync: resp=0x34

I really am not sure what I'm doing wrong....

Does that matter that ttyACM0 shows up as a device in the OpenPlotter serial list? I guess not as when I delete it the Arduino IDE can't find the port anymore.

Thanks again for your help.
Reply
#13
To upload it is /dev/ttyAMA0 not /dev/tyACM0. You must press the reset button or repower the arduino exactly when you run the avrdude command to upload.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)