This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Raspios 64 bits Raspian
#1
Finally the Raspberrypi organisation comes with a 64 bits version for the 64 bits RPI4 en RPI3.

Works great and much better then the 32 bits version.

The OpenCPN beta version also works very well. However I cannot install the OpenPlotter options on the new OS.

The system is complaining about a missing VLC version, if you like to try the OpenPlotter on Raspios.

There is also no option the generate a fingerprint for the Oesenc dongle.

Now with the 8 Giga RaspberryPi, 64 bits is the way to go.

Hope that my 64 bits RPI4 is soon working with OpenPlotter again.

Regards,


Bram

Congratulations with the new server installation. Looks very attractive.
Reply
#2
The problem with the VLC is gone. It is now also possible to install the OpenPlotter add-ons on the 64 bits RaspiOS.

Not all items work:


Openplotter-can
Openplotter-kplex
Openplotter-pypilot
Openplotter-sdr-vhf
Openplotter-signalk-installer. Complains about canboat not available

The OpenCPN 5.1.529 version works very well. Not yet support for the Oesenc dongle.

This how far I have tried the latest 64 bits Raspbian.

Bram
Reply
#3
To have an impression how well the 64 bits RaspiOS works on my RPI4 with 2 GB. Did some tests.

I have used some OpenPlotter items and installed SignalK myself.

OpenPlotter installs now on the RaspiOS. But not every Item is working.

I can report that the 64 bits is working fast with a quick respons. OpenCPN (latest beta version) works very good with the direct SignalK input.

My canbus adapter for NMEA2000 input worked without any problems.

The wait is for OpenPlotter RaspiOS version.

Bram

   
Reply
#4
(2020-06-06, 09:22 AM)verkerkbr Wrote: ... /

The wait is for OpenPlotter RaspiOS version.

Bram

Hi Everybody !
Is there any plans for this (OpenPlotter 64b) in a close future yet ?

PLEASE, let it be !
Cordialement
Didier B
Pi4, SSD, OP 2.4.1-stable, OpenCPN 5.2.0.9




Reply
#5
The most important items are working. It is probably not so difficult to make a 64 bit OpenPlotter. Some are installed by myself.

Not yet working here are:

RealVNC server
Canbus (although settings can be done in SignalK)
Kplex
SDR-VHF
Pypilot
Oesenc for the USB dongle
(Well known problem with SGLock.)

Processor temperature: With the 32 bits temperature was around 50 oC
And now with the 64 bits the temperature is around 43 o C

Bram
Reply
#6
I agree. OpenCpn on Rpi4 over Raspi-OS arm64 is a whole new beast. Really improved performance. 

[Image: 2020-06-07-012341-1920x1080-scrot.png]
Reply
#7
We will release OpenPlotter 2 for arm64 when Raspberry Pi OS (previously called Raspbian) for arm64 gets officially stable.
Reply
#8
It won't be complicated. I've been able to get what I need working without too much trouble:

Opencpn
Signal K
Grafana
Node Red
serial
Pypilot
I2C
Xygrib

[Image: 2020-06-08-001731-1920x1080-scrot.png]

I need to test it on the boat to confirm that it works but it looks good.

I needed to download a couple of missing packages from debian's sid branch and create the package for canboat. Maybe the opencpn installer is not so necessary anymore since the plugins can be installed directly from the plugin manager that will be implemented in opencpn very soon.
Reply
#9
Information 
Good news for ARM64 Openplotter users:
I'm providing now also arm64 packages for xyGrib

Code:
deb https://www.free-x.de/deb4op buster main



Have a lot of fun
BlackSea
Reply
#10
(2020-06-08, 05:45 AM)BlackSea Wrote: Good news for ARM64 Openplotter users:
I'm providing now also arm64 packages for xyGrib

Code:
deb https://www.free-x.de/deb4op buster main



Have a lot of fun
BlackSea

¡instaled! Great job.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)