This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Raspios 64 bits Raspian
#21
It's a Beta !!!
as explained  in https://www.raspberrypi.org/forums/viewtopic.php?f=117&t=275370 :

Known issues
1) There is no hardware video acceleration in VLC or Chromium
2) libraspberrypi0, libraspberrypi-dev and libraspberrypi-doc have been moved out of /opt/vc/* and into /usr/* instead (making it more standard). Any code built against these libraries will require changing to refer to a more standard location (/usr/lib/ rather than /opt/vc/lib)
3) Due to 2) Many packages that expect libGLESv2.so libEGL etc will require rebuilding.
4) raspberrypi-bootloader and raspberrypi-kernel contain useless non-64bit binaries and is missing the work done to minimise the delay between files being deleted and installed to /boot
5) There is no Wolfram Mathematica built for AArch64
6) Minecraft shim layer requires rebuilding to cope with 2)
7) VLC needs rebuild (not available)
8) VNC server not rebuilt yet for 64bit

As usual with any exciting novelties, it is wise to let some dust cover it before trying to use it !
Specially point 8 makes it less appropriate for an "on board" test !
Hope that the Org development team are active and operational ...

Now it's time to sail , and I will be very interested, say at fall, to give it a test !
Cordialement
Didier B
Pi4, SSD, OP 2.4.1-stable, OpenCPN 5.2.0.9




Reply
#22
The truth is that Raspi-OS 64 seems to work better and feels more stable than the 32 version. And it is surprising considering that being a beta version it is still missing quite a few of the tweaks Raspbian has received.

I'm using it with openplotter and I like its performance more. And I haven't been able to make pypilot work at all. Although it installs apparently well, the thing is that the compass calibration tool does not work. It's wrong to build. It says something about libwiringpi like the file is not compatible and ends up getting stuck.

Still, even without using the IMU I like more how stable it is running services in the background, especially Signal k and its connections to infulxDB and Grafana. And that's why I use it on an Rpi 4 with 2 Gb of RAM that in principle should not benefit from the use of a 64-bit system. In my opinion Raspi-OS 64-bit communicates more effectively with the 64 kernel and the 64 CPU and GPU and is therefore more fluid and stable.

So... yes. I'm sailing Raspi-OS 64 despite being a beta and missing some features.
Reply
#23
The feature I miss most is the VNC server application. The news from RealVNC is, that they are working for an arm64 version for the 64 bits RaspiOS.

But it is working very well and fast on my RPI4 with 2 GB.

Bram
Reply
#24
Can you qualify the speed difference? Like what operations are noticeably quicker?


Sent from my iPhone using Tapatalk
Reply
#25
Not that extra speed can be measured as a percentage form or anything. It's more like the system is more responsive... more sparkly. You can tell by browsing the internet or moving the charts in OpenCpn. It's like everything is going one better. I suppose that by applying the tweaks will be even more remarkable improvement. I would also say that in the graphic stack is noticeable. It's subtle but you can tell.

By the way, I've managed to replace RealVNC with X11Vnc which works fine for now. RealVNC can be installed and the system activates it if we download the deb package from its web but it doesn't work well. X11Vnc does. But we have to start it by hand.
Reply
#26
(2020-06-05, 12:33 PM)verkerkbr Wrote: Not yet support for the Oesenc dongle.

Bram

Now it's possible. You need oesenc plugin >= 4.2.11
Reply
#27
Hi Blacksea, that is good news to get my Oesenc dongle working. However where do I find this version 4.2.11 ?

It is not in de repositories at the moment.

Regards,

Bram
Reply
#28
(2020-06-21, 06:13 PM)verkerkbr Wrote: However where do I find this version 4.2.11 ?

It is not in de repositories at the moment.

you can compile by yourself
you can wait until it is available in official opencpn repos
you can use unofficial repos (but then this will bite with official ones)
Reply
#29
You can try using my build but I'm not so sure it works. My opencpn crash with segmentation fault. You can try it out for yourself.

Rename it from zip to deb to install it.


Attached Files
.zip   oesenc_pi-4.2.11-0_debian-arm64-10.zip (Size: 542.78 KB / Downloads: 2)
Reply
#30
Hi Monos1,

just tried the Oesenc-plugin compiled by you. Install well. Then I tried to use it. I get the License page from O-charts.

But the charts don't load. If i look at Synaptic the Oesenc plugin 4.2.11 is mentioned as oesenc_pi S63 chart Plugin for OpenCPN.

A pity it does not work. There is also no setting for the USB plug. Only for the fingerprint. Perhaps the SGlock files are not yet available.

Regards,

Bram
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)