This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Moitessier HAT - No GPS
#6
SkipperEarly,

- check power supply for pi is sufficient (my observation is that most problems start with bad power
          I am powering the Pi with an old 19V Dell laptop power supply through an MCS board.  I have an 
          SSD plugged into one of the Pi's USB 3 ports, and a powered USB hub plugged into the second.
          Power shouldn't be a problem.
- check Moitessier hat with cmd prompt (may need a sudo in front)
cat /dev/moitessier.tty
cat /dev/moitessier.spi

          I've not had time to do this yet, but will soon.  I'll post the results; however, I think that they,
          correct me if I'm wrong, will show the same thing as the photos above from the Moitessier HAT
          configs and the OpenCPN Debug.
- let the GPS antenna see the sky without any destruction for prolonged time (2-hrs)
          I was hoping this would help.  This morning I put my project outside for three hours and never
          had a GPS signal.
- if all doesn't help try reinstalling the op-moitessier kernel as per manual

          This is a option, but since I have the compass, accelerometer, and barometer data showing up
           I'll wait.  I suspect that the temp is working too, but I renamed it to inside.openplotter and 
           have not seen it since.

good luck in your endeavors

          Thanks for your input.


serh11,


Do you have any USB 3.0 devices connected? 
          Actually I do.  The 4 port hub in the photo is a powered USB 3 hub that is powered by a
          step down regulator.  I suppose both could be putting out RF-interference.

I'm experiencing issues caused by USB 3.0 interference, mainly with 2.4GHz WiFi and GPS. 
          Funny you should mention that.  I've been working in the house about 10 feet from my internet 
          router and have not had any WiFi problems.  Yesterday when I took my project outside, I could not 
          keep the WiFi connected.  After doing a little reading online, I thought it might be my monitor
          connected via HDMI being too close to the project.  This morning, when I took my project outdoors,
          I placed the monitor about 5 feet away and seemed to have better WiFi.

To get GPS working I had to shield raspberry with Moitessier HAT and connect external GPS antenna.
          I already bought a GPS antenna and had it hooked up, but when I didn't see any GPS data, I 
          disconnected it for fear it was the cause.  All further tests used the Moitessier HAT's antenna.  


          How did you shield your Raspberry Pi?  I posted a photo of my project in the first post.  This
          is a likely cause as nothing is shielded.

So I would suggest to try to disconnect USB and reset Moitessier HAT and see if you get an improvement.

          Currently, the only device attached to the hub is the WiFi dongle.  The other two cables connect to 
          USB ports on the case and currently have nothing plugged in.  I can un-power the hub and plug the 
          WiFi dongle directly into pi to test this.  I will try later when I have time and post the results.


Thanks for the help so far.  I'd really like to get this stable so I can begin configuring it for my boat.
Reply


Messages In This Thread
Moitessier HAT - No GPS - by jamieFL - 2020-06-16, 02:33 PM
RE: Moitessier HAT - No GPS - by Sailoog - 2020-06-16, 05:40 PM
RE: Moitessier HAT - No GPS - by jamieFL - 2020-06-16, 10:04 PM
RE: Moitessier HAT - No GPS - by SkipperEarly - 2020-06-17, 08:07 AM
RE: Moitessier HAT - No GPS - by serh11 - 2020-06-17, 02:00 PM
RE: Moitessier HAT - No GPS - by jamieFL - 2020-06-17, 05:17 PM
RE: Moitessier HAT - No GPS - by serh11 - 2020-06-18, 09:50 AM
RE: Moitessier HAT - No GPS - by holgerw - 2020-06-18, 08:35 PM
RE: Moitessier HAT - No GPS - by glowntiger - 2020-06-19, 12:10 PM
RE: Moitessier HAT - No GPS - by jamieFL - 2020-06-19, 12:52 PM
RE: Moitessier HAT - No GPS - by glowntiger - 2020-06-19, 01:04 PM
RE: Moitessier HAT - No GPS - by jamieFL - 2020-06-20, 12:16 AM
RE: Moitessier HAT - No GPS - by jamieFL - 2020-06-21, 03:27 PM
RE: Moitessier HAT - No GPS - by glowntiger - 2020-06-22, 08:03 AM
RE: Moitessier HAT - No GPS - by jamieFL - 2020-06-21, 04:34 PM
RE: Moitessier HAT - No GPS - by Sailoog - 2020-06-22, 04:42 PM
RE: Moitessier HAT - No GPS - by jamieFL - 2020-06-25, 04:28 PM

Forum Jump:


Users browsing this thread: 1 Guest(s)