This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Hydraulic controller and LS drive unit
#1
Hello,

I have a Raymarine autopilot system I believe from 2003 with S3 course computer and Lecomble & Schmitt hydraulic drive unit (Linear drive ST 40 DE BP 12 v + Power pack RV2 ST 12 V) fitted to a quadrant on First 40.7. Now it looks like that when I managed to blow a fuse while doing rewirings to Seatalk systems, I may have caused permanent damage to the course computer. So I would like to replace it with Tinypilot setup.  It seems that the drive unit cannot be run with pypilot motor controller but would the hydraulic controller work? LS recommends 25A fuse for this power pack on a 12 V system while the hydraulic controller description says up to 20 A.

A link to the LS drive unit manuals:  [Power Packs and Linear Drives for Autopilots : Instruction Manuals, Catalogues - Lecomble & Schmitt](https://www.ls-france.com/en/instruction...atalogues/

EDIT:

In addition, there is a Raymarine rudder position sensor + clutch but I assume neither of these should be an issue

Best, Jani
Reply
#2
can you connect the hydraulic pump directly to the battery and measure the current while it is moving the rudder?

The hydraulic controller can also use a 30 amp fuse but I put 20 amp fuses. The idea is the controller never gets more than 5 degrees above ambient with currents 20 amps and less.
Reply
#3
(2020-06-24, 03:51 PM)seandepagnier Wrote: can you connect the hydraulic pump directly to the battery and measure the current while it is moving the rudder?

The hydraulic controller can also use a 30 amp fuse but I put 20 amp fuses.   The idea is the controller never gets more than 5 degrees above ambient with currents 20 amps and less.

Thanks for the suggestion! Unfortunately I was not able to get the measurements so I got into touch with LS directly and they were kind to provide a power consumption curves (attached) plus further info: "Although the average power consumption is around 6 – 7 Amp, it can reach 25 Amp peaks by rough sea conditions when the cylinder has to push hard and the pressure rises." Pretty hard to say how likely that is to happen...


Attached Files
.pdf   COURBE 40 ST 16 12V.pdf (Size: 550.74 KB / Downloads: 9)
Reply
#4
So just wondering if the best compromise would be to switch a 25A fuse to the hydraulic controller. Peaking over 20A should happen rarely and in most occasions the current draw would remain in 6-7A, keeping things cool
Reply
#5
It sounds like it would be very unlikely you will ever get anywhere near 25 amps except maybe in extreme conditions (sailing hard in rip currents) etc..

takes about 2 minutes for this 20 amp fuse to actually blow at 25 amps continuous. Since autopilot is intermittent it would be unlikely it would ever actually blow, but you could use a 30 amp fuse instead.
Reply
#6
(2020-07-02, 05:44 PM)seandepagnier Wrote: It sounds like it would be very unlikely you will ever get anywhere near 25 amps except maybe in extreme conditions (sailing hard in rip currents) etc..

takes about 2 minutes for this 20 amp fuse to actually blow at 25 amps continuous.   Since autopilot is intermittent it would be unlikely it would ever actually blow, but you could use a 30 amp fuse instead.

Excellent, thanks! We are mostly in Finnish archipelago, I do not think we get to such conditions.
Reply
#7
Quote: It seems that the drive unit cannot be run with pypilot motor controller
Hi
I was building a wiper motor based autopilot  using the tiniypilot computer and pypilot controller from Sean's store but have just acquired an Lescomble and Schmitt hydraulic linear drive which seems to be a better overall solution. Is there a problem using the pypilot controller with an L&S hydraulic drive.? In my test rig the controller does move the cylinder but not through its full sweep, when you would expect it to. Do I need to get a new controller or is this a matter of configuration.




Apologies if this has been answered elsewhere
Thanks
Richard
Reply
#8
It will work with any reversible drive. So can you get the full range of motion by applying power directly in each direction?

You can measure the current draw moving the rudder to know if the controller can handle it, or it may just overheat and trigger the "over temp" fault until it cools This is somewhat difficult to do.

As far as not moving over the full sweep, did you connect rudder feedback? If so, it's likely the default rudder feedback calibration is limiting movement so you may need to reset and re calibrate this. Otherwise I'm not sure what could limit the range.
Reply
#9
Hi
Thanks for getting back. If I apply power directly to the motor I get the full range of motion in the ram, about 25cm

I will try to measure the draw but at the moment it is unladen.. the ram is not attached to anything, so draw should be low

I have not connected rudder feedback.. current set up is just a the clutch , the pi and the controller wired directly to the battery, when I run it like this the ram moves about 5 cm in one direction and will not move again untill I swing the pi back in the other direction, when it moves 5cm the other way.

What limits how far the motor will attempt to turn the rudder.. is it the resistance when it hits the stops or is that a config setting?
Thanks
Reply
#10
[attachment=1133 Wrote:rsairving@hotmail.com pid='16976' dateline='1605178814']Hi
Thanks for getting back. If I apply power directly to the motor I get the full range of motion in the ram, about 25cm

I will try to measure the draw but at the moment it is unladen.. the ram is not attached to anything, so draw should be low

I have not connected rudder feedback.. current set up is just a the clutch , the pi and the controller wired directly to the battery, when I run it like this the ram moves about 5 cm in one direction and will not move again untill I swing the pi back in the other direction, when it moves 5cm the other way.

What limits how far the motor will attempt to turn the rudder.. is it the resistance when it hits the stops or is that a config setting?
Thanks

In the settings or "config" there is a line called servo.max_current, this setting is used as a software end stop. Basically when there is more resistance against the motor it uses more amperage and therefore that is the end stop, pypilot will only allow the motor to turn the other way, if this is too low it may result as you have stated above, try increasing this value and see if that solves your problem.


Attached Files Image(s)
   
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)