This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
I2c and Imu stopped working.
#1
My compass died yesterday. I do not see any I2c addresses from any equipment at all which is very frustrating. Tips on where to start trouble shooting?
Running i2cdetect gives me nothing. Removing i2c devices so I only have my pijuice still gives me nothing. To be clear - it HAS worked previously
Reply
#2
I have heard other reports of failed sensors.... I don't really think pypilot has done anything that could cause this.

The next step is to try different sensors and different pi with same sd card. If that works, try old sensors with new pi and new sensors with old pi.
Reply
#3
*some trouble shooting later...*
Using i2cdetect I realized none of my i2c devices were found. Strange - since they had been working. Even the can, which was attached as a hat on the pi was missing. Swapped the pi for a new and everything is back to normal.
Reply
#4
You might want to consider what could have burned the i2c bus on that pi so it doesn't repeat. Do you have long wires on i2c?
Reply
#5
(2020-06-26, 01:53 AM)seandepagnier Wrote: You might want to consider what could have burned the i2c bus on that pi so it doesn't repeat.   Do you have long wires on i2c?

Yes I do, but I have a I2C range extender on it so it shouldnt be an issue.
Reply
#6
maybe the i2c range extender _is_ the issue? I am speculating, but using i2c extenders is very rare so it seems an obvious culprit.
Reply
#7
I use these: https://www.ebay.com/itm/I2C-IIC-Active-...2292264539
As my RPI is installed alongside my VHF, radio, stepdown transformers etc. In order to avoid electromagnetic interference on the IMU, I wanted to move it away from the Pi.
Reply
#8
I'm having a similar problem -- IMU worked previously now it's flaky. Which would you recommend changing out first? New IMU (soldered to pypilot board) or new RPi?
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)