This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[CLOSED] i2c broke after update
I2C bug

I run Openplotter on the MCS board with Rpi4 and Moitessier Hat.
All worked fine together until i recently updated the FW on the Hat.
Latest version of all packages as of yesterday.

Openplotter system check now complains that i2c is disabled.
Raspberry Pi config shows i2c is enabled.
If i disable i2c in Raspberry Pi config - everything freezes instantly.

Seems like i2c is actually working fine but system check won't accept it and disables lots of things.

/boot/config ends like this:
#MCS-Openplotter config (Do not delete or edit this part)(start)
#MCS-Openplotter config (Do not delete or edit this part)(end)

Moitessier Hat reports this:
opening device /dev/moitessier.ctrl
size - 204
mode - A
hardware ID - P770010
hardware version - E04
boot version - 
app version - 1.6.0
gnss version - L86NR02A01S
functionality - 0xffffffff
system errors - 0x00000000
serial - 20383439434e43198002000a

i2c app complains about i2c being disabled and can't do anything.
it lists the two i2c sensors that are attached to the Hat (MS5607-02BA03).

Jeanneau Sun Odyssey 42.2 - All Openplottered and hooked up on online.
Fixed it by reinstalling MCS
Jeanneau Sun Odyssey 42.2 - All Openplottered and hooked up on online.

Forum Jump:

Users browsing this thread: 1 Guest(s)