This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
OP 2 went black - possibly after update
Hey sailors!

I encounter an issue with my OP 2 installation.
Had the same thing on my test-system at home but now it happens to me while sailing.
Usually I could deal without a working desktop on OP but avnav ocharts plugin seems to need a running desktop somehow and now I end up without my licensed cards Sad

What happened: 
VNC stopped showing the desktop. "can not currently show the desktop" -> black screen.
I checked google for that and found some steps like resetting the resolution in raspi-config.
None of them helped. 

Any ideas what to check or to do now? 
When I type "startx" manually, x11 crashes with segmentation fault. Don't know if thats normal but I thought the vnc server needs a running x11?

It's a little nasty at sea now not having the licensed charts. I know this is all beta and I really love playing and experimenting but its just a bad timing now Smile

Hmm, not sure what the problem really could be.
AvNav (and the ocharts plugin) is completely independent of any desktop (internally it uses Xvfb - but this should not affect you at all). You can also nicely run this on a headless system.

It for sure makes no sense to start an X server as you would like to use VNC - so you need to run a VNC server. Not sure which one was used before.
For AvNav all of this is not really necessary - just connect with the browser from your device to the AvNav port at your openplotter (normally 8082).
As long as AvNav is running this should be completely ok.

If you want to continue with the desktop most probably someone else could help. But you should always be able to just fire up vncserver and connect from your client (maybe not really the desktop...).

If AvNav ist not running - try (as you have a console I assume):
sudo systemctl start avnav
if you want to use openplotter without connecting a monitor you have to be sure VNC server is enabled and openplotter settings - raspberry settings - headless is enabled too
Hi guys,
thanks for you reply.

AvNav by itself doesn't seem to need any X - but O-Charts plugin does, doesn't it? At least it fired up Unable to initialize GTK+ and complained about the "DISPLAY" ..

I got X back running (I think the problem wasn't caused by an update but a faulty SD card) and had my cards (and the o-Charts plugin) back running.

So this neither was an issue of OP nor AvNav. I was just wondering why the o-charts plugin wouldn't start without GTK+. Maybe also a problem of corrupted files - maybe the GTK lib.

However.. Andreas, I sent you a mail, just before reading this, so just ignore that part.

OP and AvNav doing a great job again!

Regards and thanks for you help,
I donot think this is a o-charts plugin issue either.

Try adding or uncomment this line in /boot/config.txt:


Forum Jump:

Users browsing this thread: 1 Guest(s)