This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
problem installing moitessier firmware
#1
I just re-installed version 2.1
When I try to update the firmware, I get this message:




Could not load "./moitessier_5.4.51-v7+.ko".
******************************************************************************************


******************************************************************************************
ERROR occured!!

You might try to install the package again.
******************************************************************************************

dpkg: error processing package moitessier (--install):
 installed moitessier package post-installation script subprocess returned error exit status 1
Errors were encountered while processing:
 moitessier



I run Kernel 5.4.51-v7+
I cannot see the GPS device in Serial devices, only my 2 usb devices (can-usb and wind adaptor)

I am without resources, can't sail without GPS...
Richard

Alberg 30 #597 on Lake of Two Mountains, Quebec, Canada
Reply
#2
it seems that your error report is not complete
Download: https://get.rooco.tech/moitessier/buster..._armhf.deb
open a terminal and run:

sudo dpkg -i moitessier_5.4.51_2.1.0_armhf.deb

and copy here the complete error output
Reply
#3
FIRMWARE UPDATE SUCCESSFULL!!!
******************************************************************************************

insmod: ERROR: could not insert module ./moitessier_5.4.51-v7+.ko: Input/output error

******************************************************************************************
ERROR occured!!

Could not load "./moitessier_5.4.51-v7+.ko".
******************************************************************************************


******************************************************************************************
ERROR occured!!

You might try to install the package again.
******************************************************************************************

dpkg: error processing package moitessier (--install):
 installed moitessier package post-installation script subprocess returned error exit status 1
Errors were encountered while processing:
 moitessier
Richard

Alberg 30 #597 on Lake of Two Mountains, Quebec, Canada
Reply
#4
(2020-07-28, 06:21 PM)opampca Wrote: FIRMWARE UPDATE SUCCESSFULL!!!
******************************************************************************************

insmod: ERROR: could not insert module ./moitessier_5.4.51-v7+.ko: Input/output error

******************************************************************************************
ERROR occured!!

Could not load "./moitessier_5.4.51-v7+.ko".
******************************************************************************************


******************************************************************************************
ERROR occured!!

You might try to install the package again.
******************************************************************************************

dpkg: error processing package moitessier (--install):
 installed moitessier package post-installation script subprocess returned error exit status 1
Errors were encountered while processing:
 moitessier

I find the same, identical problem. I thought it was due to conflict with the MCS card ... do I have to change my mind? The "serial" app does not see / receive, while USB is ok.  Huh
Reply
#5
(2020-07-28, 06:21 PM)opampca Wrote: FIRMWARE UPDATE SUCCESSFULL!!!
******************************************************************************************

insmod: ERROR: could not insert module ./moitessier_5.4.51-v7+.ko: Input/output error

******************************************************************************************
ERROR occured!!

Could not load "./moitessier_5.4.51-v7+.ko".
******************************************************************************************


******************************************************************************************
ERROR occured!!

You might try to install the package again.
******************************************************************************************

dpkg: error processing package moitessier (--install):
 installed moitessier package post-installation script subprocess returned error exit status 1
Errors were encountered while processing:
 moitessier

Raspberry 3 or 4?
Moitessier HAT 1 or 2?
Reply
#6
raspberry 3b 
with first gen hat
Richard

Alberg 30 #597 on Lake of Two Mountains, Quebec, Canada
Reply
#7
(2020-07-28, 06:33 PM)Sailoog Wrote:
(2020-07-28, 06:21 PM)opampca Wrote: FIRMWARE UPDATE SUCCESSFULL!!!
******************************************************************************************

insmod: ERROR: could not insert module ./moitessier_5.4.51-v7+.ko: Input/output error

******************************************************************************************
ERROR occured!!

Could not load "./moitessier_5.4.51-v7+.ko".
******************************************************************************************


******************************************************************************************
ERROR occured!!

You might try to install the package again.
******************************************************************************************

dpkg: error processing package moitessier (--install):
 installed moitessier package post-installation script subprocess returned error exit status 1
Errors were encountered while processing:
 moitessier

Raspberry 3 or 4?
Moitessier HAT 1 or 2?
In my case: Raspberry 4 and Moitessier Hat 1.
Reply
#8
Check system results :

Moitessier HAT is attached.
I2C is enabled.
SPI is enabled.
Moitessier HAT package is installed.
Package: moitessier
Status: install ok half-configured
Maintainer: Thomas POMS <hwsw.development@gmail.com>
Architecture: armhf
Version: 2.1.0
Description: Moitessier HAT (AIS/GNSS navigation)

Check configuration results:

AIS - GNSS
Device: /dev/moitessier.tty
Connection: not connected
Compass - Trim - Heel
Pypilot mode: only compass
Connection: not connected
Signal K to NMEA 0183 plugin: disabled
   Heading conversion: disabled
   Trim - Heel conversion: disabled
Pressure - Temperature
I2C - Signal K key for pressure: environment.outside.pressure
I2C - Signal K key for temperature: environment.inside.openplotter.temperature
Connection: not connected
Signal K to NMEA 0183 plugin: disabled
   Pressure conversion: disabled
Richard

Alberg 30 #597 on Lake of Two Mountains, Quebec, Canada
Reply
#9
Have you noticed, that there are two packages available for the 5.4.51 kernel?
https://www.rooco.eu/2018/06/13/firmware...ssier-hat/

Unfortunately Raspberry has released two different kernel commits but with the same kernel version.

Please try to install both package and report if this solves the issue.

Regards,
Thomas
Reply
#10
Unfortunatly, same results....

FIRMWARE UPDATE SUCCESSFULL!!!
******************************************************************************************

insmod: ERROR: could not insert module ./moitessier_5.4.51-v7+.ko: Input/output error

******************************************************************************************
ERROR occured!!

Could not load "./moitessier_5.4.51-v7+.ko".
******************************************************************************************


******************************************************************************************
ERROR occured!!

You might try to install the package again.
******************************************************************************************

dpkg: error processing package moitessier (--install):
 installed moitessier package post-installation script subprocess returned error exit status 1
Errors were encountered while processing:
Richard

Alberg 30 #597 on Lake of Two Mountains, Quebec, Canada
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)