This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Signal K Server not Running
I am just getting to grips with a new installation of OpenPlotter on a Pi 4b. So far I have it hooked up to my boats Seatalk/NMEA network through a ShipModul MultiPlexer and it all works beautifully.

I would like to send this data via Signal K via wifi however I cannot get the Signal K server to start. It was running on the fresh installation but since updating it and turning on the access point it is no longer running. I wonder if anyone can help.

I have tried to use the SignalK installer, which tells me it is successfully installed, but then the server is not running. 
When I try to run it through the terminal with
signalk-server run

I get the following response:

unable to parse /home/pi/.signalk/defaults.json
SyntaxError: Unexpected end of JSON input
   at JSON.parse (<anonymous>)
   at readDefaultsFile (/usr/lib/node_modules/signalk-server/lib/config/config.js:189:17)
   at setFullDefaults (/usr/lib/node_modules/signalk-server/lib/config/config.js:194:31)
   at Object.load (/usr/lib/node_modules/signalk-server/lib/config/config.js:57:9)
   at new Server (/usr/lib/node_modules/signalk-server/lib/index.js:51:32)
   at Object.<anonymous> (/usr/lib/node_modules/signalk-server/bin/signalk-server:20:16)
   at Module._compile (internal/modules/cjs/loader.js:778:30)
   at Object.Module._extensions..js (internal/modules/cjs/loader.js:789:10)
   at Module.load (internal/modules/cjs/loader.js:653:32)
   at tryModuleLoad (internal/modules/cjs/loader.js:593:12)
So I have tried to set up signalk through the terminal with


However the server is still not running after the setup. When I try to run it through the terminal I get:

Could not parse security config
ENOENT: no such file or directory, open '/home/pi/.signalk/security.json'
 throw err;

Error: Could not locate the bindings file. Tried:
→ /usr/lib/node_modules/signalk-server/node_modules/@serialport/bindings/build/bindings.node
→ /usr/lib/node_modules/signalk-server/node_modules/@serialport/bindings/build/Debug/bindings.node
→ /usr/lib/node_modules/signalk-server/node_modules/@serialport/bindings/build/Release/bindings.node
→ /usr/lib/node_modules/signalk-server/node_modules/@serialport/bindings/out/Debug/bindings.node
→ /usr/lib/node_modules/signalk-server/node_modules/@serialport/bindings/Debug/bindings.node
→ /usr/lib/node_modules/signalk-server/node_modules/@serialport/bindings/out/Release/bindings.node
→ /usr/lib/node_modules/signalk-server/node_modules/@serialport/bindings/Release/bindings.node
→ /usr/lib/node_modules/signalk-server/node_modules/@serialport/bindings/build/default/bindings.node
→ /usr/lib/node_modules/signalk-server/node_modules/@serialport/bindings/compiled/10.20.1/linux/arm/bindings.node
→ /usr/lib/node_modules/signalk-server/node_modules/@serialport/bindings/addon-build/release/install-root/bindings.node
→ /usr/lib/node_modules/signalk-server/node_modules/@serialport/bindings/addon-build/debug/install-root/bindings.node
→ /usr/lib/node_modules/signalk-server/node_modules/@serialport/bindings/addon-build/default/install-root/bindings.node
→ /usr/lib/node_modules/signalk-server/node_modules/@serialport/bindings/lib/binding/node-v64-linux-arm/bindings.node
   at bindings (/usr/lib/node_modules/signalk-server/node_modules/bindings/bindings.js:126:9)
   at Object.<anonymous> (/usr/lib/node_modules/signalk-server/node_modules/@serialport/bindings/lib/linux.js:2:36)
   at Module._compile (internal/modules/cjs/loader.js:778:30)
   at Object.Module._extensions..js (internal/modules/cjs/loader.js:789:10)
   at Module.load (internal/modules/cjs/loader.js:653:32)
   at tryModuleLoad (internal/modules/cjs/loader.js:593:12)
   at Function.Module._load (internal/modules/cjs/loader.js:585:3)
   at Module.require (internal/modules/cjs/loader.js:692:17)
   at require (internal/modules/cjs/helpers.js:25:18)
   at Object.<anonymous> (/usr/lib/node_modules/signalk-server/node_modules/@serialport/bindings/lib/index.js:14:22)

There is no security.json file and there is no bindings file either.

I would really appreciate some assistance or a point in the right direction.
I feel like it must be simple, because it was all working fine before I updated it....

Forum Jump:

Users browsing this thread: 1 Guest(s)