This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Thread Rating:
  • 1 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[SOLVED] Raspberry 4 + moitessier hat / signalk -> opencpn: freeze
#31
After a few hours, my configuration, (with  the latest updates) couldn't give me a FIX !
Using my "gold (old) SD" card, I made a new copy to SSD, and then I updated it as follows :
  1. Settings updated 2.5.0
  2. Documentaton updated 2.0.10
  3. OpenCPN installer updated 2.2.1 
  4. XyGrib 1.2.6-1  (unchanged)
  5. Signal K installer : 2.1.0 Not updated, as 2.3.0 replaces Signal K 1.26 with Signal K 1.35-2 which causes the absence of FIX !
  6. Dashboard updated 2.2.1
  7. Network (?) 2.1.4
  8. Serial 2.1.0 Not updated (to keep consistency with Signal K which was not updated neither)
  9. Then I updated openCPN to 5.2.4

And now, I got a configuration which works perfectly, giving me quick FIX (few sec.) at any launch, both with the old school (TCP) and newer (Signal K) connections !

I will not anticipate, and wait for a few hours to bet my life on that, but it seems that the impossibility for signal K 1.35-2 to access /dev/ttyOP_gnss (see previous screen shot) is the Gordian Knot !

EDiT 2 hours later : in facts, the simple update of Settings to 2.5.0 seems to prevent any FIX ! I had to roll back to settings 2.4.1

So my (working) configuration is Settings 2.4.1, Signal K installer 2.1.0, Signal K 1.26, Serial 2.1.0, Open CPN installer 2.2.1 and OpenCPN 5.2.0.
In that configuration both types of connections (TCP & Signal K) seem to work equally...
Cordialement
Didier B
Pi4, SSD USB3, OP 2.6.2, OC  5.2.4




Reply
#32
I was browsing the web when I reached this video posted 3 months ago  by a radio ham operator : KMACK
If I understood clearly, the fact to activate an USB3.0 port resulted repeatedly  in the loss of GPS signals on his RPi4, so I wonder if this was not the cause of my almost passed week agony Huh Angry

I am using an USB3.0 SSD, and I had noted also the problem was not showing up, never, when using an SD card instead...

My GPS pucks has a rather thin cable (with no much shielding, may be none!) 2 m length, and it was located at around 90 cm of my Pi4. I first moved it to a longer distance(~ 1.8m).
I plugged the USB 3.0 disk in an USB 2.0 port, I did all updates (OP 2.5.0, OpenCPN 5.2.4), activated signal K connection, and, at each start-up, 

Heart Heart Heart  A STEADY FIX IS NOW REPEATEDLY REACHED BEFORE THE O-CHARTS MESSAGE IS DISPLAYED !!!  Heart Heart Heart

After a generous whiskey shot Tongue ,  I reconnected the USB Disk to an USB 3.0 port, to see what happens, so far so good...
Sailoog, you were right suspecting gps signal quality, but  the problem was not in the sky viewing, but in RF interference with the RPi4 own USB3 circuitry !
OK, that was probably the source of the issue, we can take for highly probable in Raspberry Pi4 than RF interference caused by the USB3.0 circuitry vicinity can corrupt the GPS signals, specially when the GPS, or its antenna (?), is close to the RPii4 ...
Cordialement
Didier B
Pi4, SSD USB3, OP 2.6.2, OC  5.2.4




Reply
#33
Glad to read that!
closing this thread, re-open if necessary.
Reply
#34
(2020-10-25, 11:08 PM)Didier B Wrote: I plugged the USB 3.0 disk in an USB 2.0 port, I did all updates (OP 2.5.0, OpenCPN 5.2.4), activated signal K connection
So, to stop using USB 3.0 is the only way way to avoid freeze? Should we continue to discuss this harware bug at RaspberryPI forum?
Reply
#35
latest opencpn version should fix the jumping boat and the freeze issues. This USB 3.0 issue is about dab GPS reception due to interferences and should be fixed by raspberry devs or solved moving away the gps antenna from the raspberry.
Reply
#36
This is my first post in this place i hope i do it correctly.

In my RapsberryPi 4 with 8G ram 32GB sd card and installed and upgraded all newest packets with software i cannot connect SignalK to OPENCPN .

SignalK serwer is working i can add SDR Rtl, I2C sensors, GPS, but when im trying to connect OPENCPN to SignalK server it dont wont to connect. Im using standard connection in OpenCpn for SignalK on localhost and port 3000, signal and serwer is "detected " by OpenCPN properly during adding the conection but it not working after acceptation - not connecting to OPENCPN and OPENCPN not reciving any data from SignalK

Reply
#37
(2020-12-01, 02:50 PM)Divemaster Wrote: This is my first post in this place i hope i do it correctly.

In my RapsberryPi 4 with 8G ram 32GB sd card and installed and upgraded all newest packets with software i cannot connect SignalK to OPENCPN .

SignalK serwer is working i can add SDR Rtl, I2C sensors, GPS, but when im trying to connect OPENCPN to SignalK server it dont wont to connect. Im using standard connection in OpenCpn for SignalK on localhost and port 3000, signal and serwer is "detected " by OpenCPN properly during adding the conection but it not working after acceptation - not connecting to OPENCPN and OPENCPN not reciving any data from SignalK


Hi Divemaster,
In Opencpn, your only connection should be, from left to right :
        Enable (yes), Network, Input, Signal K, localhost, 3000 , priority : 1 .

Of course as OpenCPN will receive signal K flow and no NMEA flow, the NMEA debug window will not be populated and stay empty... Sad
Add the 'GPS in view' to your dashboard. If not empty, then OpenCPN do receives your GPS info.
Getting a FIX is indicated by the ship icon red color, and the 3 bars in the compass/GPS/status window. 
That indicator is controlled by a tick box in the options/Customization panel.

About delay in getting 1st FIX : GPS needs to receive, from the satellites, 'Almanac' data about their status, positions and trajectories, before being able to deliver a FIX (position).
This 'Almanac' data, being non-real time, is carried by very slow sub channels, and it take many minutes/hours before it can be collected by your GPS puck (coldstart).
Happily, in your GPS module is a RAM and a tiny battery, which avoid that delay at each startup (warmstart), as the Almanac data remains valid for some period.
(don't ask me how long !).
Make sure your GPS has a good sky view, and if you use USB3, keep it at the cable length distance (>1.5 m)from the RPI !
Be patient and let it work overnight !

Batteries having limited life span, if you start a long passage you should have a fresh spare GPS onboard !
I have not found a GPS puck with a replaceable battery so far, programed obsolescence ! Angry

If, like me, you hardly can say goodbye to the NMEA debug  window, I will post a work around in "How I did it" in the coming days ...
Cordialement
Didier B
Pi4, SSD USB3, OP 2.6.2, OC  5.2.4




Reply
#38
(2020-12-12, 07:23 PM)Didier B Wrote:
(2020-12-01, 02:50 PM)Divemaster Wrote: This is my first post in this place i hope i do it correctly.

In my RapsberryPi 4 with 8G ram 32GB sd card and installed and upgraded all newest packets with software i cannot connect SignalK to OPENCPN .

SignalK serwer is working i can add SDR Rtl, I2C sensors, GPS, but when im trying to connect OPENCPN to SignalK server it dont wont to connect. Im using standard connection in OpenCpn for SignalK on localhost and port 3000, signal and serwer is "detected " by OpenCPN properly during adding the conection but it not working after acceptation - not connecting to OPENCPN and OPENCPN not reciving any data from SignalK


Hi Divemaster,
In Opencpn, your only connection should be, from left to right :
        Enable (yes), Network, Input, Signal K, localhost, 3000 , priority : 1 .

Of course as OpenCPN will receive signal K flow and no NMEA flow, the NMEA debug window will not be populated and stay empty... Sad
Add the 'GPS in view' to your dashboard. If not empty, then OpenCPN do receives your GPS info.
Getting a FIX is indicated by the ship icon red color, and the 3 bars in the compass/GPS/status window. 
That indicator is controlled by a tick box in the options/Customization panel.

About delay in getting 1st FIX : GPS needs to receive, from the satellites, 'Almanac' data about their status, positions and trajectories, before being able to deliver a FIX (position).
This 'Almanac' data, being non-real time, is carried by very slow sub channels, and it take many minutes/hours before it can be collected by your GPS puck (coldstart).
Happily, in your GPS module is a RAM and a tiny battery, which avoid that delay at each startup (warmstart), as the Almanac data remains valid for some period.
(don't ask me how long !).
Make sure your GPS has a good sky view, and if you use USB3, keep it at the cable length distance (>1.5 m)from the RPI !
Be patient and let it work overnight !

Batteries having limited life span, if you start a long passage you should have a fresh spare GPS onboard !
I have not found a GPS puck with a replaceable battery so far, programed obsolescence ! Angry

If, like me, you hardly can say goodbye to the NMEA debug  window, I will post a work around in "How I did it" in the coming days ...

Thank you Didier,
I have been pounding away trying to get the satellite bar status to come up in the dashboard all night. It’s been working all along. LoL
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)