This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
real VNC Server not installing
New Pi 4, new download, new Moitessier hat. --  No VNC icon in top bar. 

If it isn't an image problem, how do I turn it on?  Nothing in the manual except a reference to the need for it to be "enabled".  This recommendation doesn't provide any clues as to how or where.
I don't see it in the OpenPlotter Apps Settings 2.4.1 list. It doesn't show up in the openplotter-serial list.  A search of the file system doesn't show it anywhere, but I did find a VNC server in "Add Remove Programs" real-vnc-server-  It has a check next to the box icon.
Should I re-install it?  What I am wondering is why after so many successful installations in the past, I can no longer get one with VNC on it as part of the OP installation.  

I've re-downloaded both the image and Noobs version and tried both on freshly formatted SD cards.  In the past after the final update, the VNC icon would be next to the Bluetooth Icon on the top right of the main screen (desktop)  I never had to install Real VNC Server before, yet in my multiple attempts to find a clean install with it included, none of the recent download and installs resulted in a running system with VNC server up and running (and no task bar icon on the desktop).

My other comment on VNC is that the OP manual describes the headless access occurring on but in my experience, it needed to happen on the IP address that the network assigned the Pi.  I'd look at the VNC Server drop down box that flys out of the desktop icon for the ip address.  This worked until you powered down and rebooted.  All things being the same, the IP address assigned to the Pi wasn't always the same.  That makes headless mode harder.
OK, I did manage to get this working after filing the bug report.

I uninstalled the realVNCserver and then reinstalled it.
Following a reboot, I opened a terminal session, and ran sudo raspi-config.
Under the (5) Interfacing Options submenu, I selected (P3) VNC and enabled it by selecting YES
and then rebooted.

Alternately, under Application menu\Preference\Raspberry Pi Configuration you can bring up
a more graphical interface for making the same selection. Just select the Interfaces tab and then enable VNC.
After reboot, the VNC icon appears in the top task bar and a VNC Connect Server box pops up with Connectivity and Security information.

If you don't like the location of the VNC icon in the top menu bar, right click in the bar and select "Add/Remove
Panel Items". The list that comes up, not only shows what is available, but it also determines the order of the icons. Use the UP/DOWN buttons to change this order. You can see the immediate effect of your selections in the menu bar.
I added a display for the CPU temperature next to the Bluetooth icon, and slid the VNC icon to the left of the temperature display.

My VNC server does not come up on 10.10.10,1. This is different than what the OP manual describes.
Since my IP address is not static, when it changes, I have to find out what the new one is before I can use the Pi in headless mode.

I hope this helps someone else.
If anyone knows the answer to the problem shout back.
To get vnc on you need to be logged on to the openplotter network.
Vnc should work fine straight away in a fresh install.

Forum Jump:

Users browsing this thread: 1 Guest(s)