This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Can't get OP I2C app to recognize MPU9250
I'm a novice OP user experimenting with a Raspberry Pi 4, having been inspired by the "OpenPlotter Instruction Video for Raspberry Pi" on YouTube.
Using the most recent (2020-03-24) OP "Starting" NOOBS image, I've successfully connected a GSTAR IV GPS via UPS, and attached a Wingoneer GY-81 board containing an MPU9850 and BMP280 to the RP I/O ports.

When I run the OpenPlotter I2C app, it detects the BMP280 at address 0x76, but not the MPU9850.

If I run i2cdetect -y 1, it detects the BMP280 address (0x76), and also an additional address 0x68, which I assume is the MPU9850.

There doesn't seem to be any way to manually configure the MPU9850 in the OpenPlotter I2C app, so I don't know how I can get the information from this chip into Signal K.

Thanks in advance to anyone who can assist.

Attached Files Image(s)
IMUs in openplotter are managed by pypilot app, not by I2C app, but MPU9850 is not supported. Only these IMUs are supported:

Forum Jump:

Users browsing this thread: 1 Guest(s)