This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Would OpenPlotter work on Ubuntu?
#11
does pypilot work on the x86 ver or raspbian? or is it the i2c gpio things that make it incompatible.
mare liberum
Reply
#12
(2020-10-13, 12:38 PM)jim321 Wrote: https://github.com/sailoog/openplotter-d...mu-sensors

ah, ok, the experimental was BMX055 but AFAIK the mentioned BNO055 RaspberryPi/Pi2 clock-stretching issues have not been solved for RPi 3 or 4 either.
Reply
#13
(2020-10-13, 12:57 PM)jim321 Wrote: does pypilot work on the x86 ver or raspbian? or is it the i2c gpio things that make it uncompatable.

there are GPIO python packages as dependencies that only exists for Raspberry OS. Sean could have better info.
Reply
#14
(2020-10-13, 12:38 PM)verkerkbr Wrote:
(2020-10-13, 11:38 AM)Sailoog Wrote: I have just installed openplotter-settings in ubuntu focal 64 and it works ok, no errors about GDM3 or anything.
There is only a nonm critical issue, loaded sources are for bionic and not for focal, it works but the correct way should be loading focal sources. This will be fixed in next openplotter-settings update and then we will be ready for the next Debian version too when released.

Hi. Sailoog,


OpenPlotter add-ons works very well on my Focal version for AMD64. But with the Focal version for the RPI I get the mentioned errors.

Now trying the beta Groovy Gorilla on my AMD64. This works very well with kernel 5.8. OpenCPN is also in de repository. However it is onlty version 5.

Now installed version 5.2 by changing the settings in the server addresses to Focal instead of Groovy.

Works also and is very fast. Almost too fast for screen movement. The plugins can also installed, including the Oesenc plugin.

Not yet tried the Openplotter add-ons.

But not yet working with an Oesenc card and the dongle.

Regards,

Bram

At first the plugins work with OpenCPN 5.2 also the Oesenc plugin. But still not working.

Then I revert to an older problem and installed libusb-0.1-4 and libusb -1.0.-0

Now I have my Oesenc charts on Groovy Gorilla working in combination with the Oesenc dongle.

It is always the problem with the missing libusb. to get the dongle working.

Bram
Reply
#15
Now tried the Groovy Gorilla on the Raspberry Pi4. This also works with OpenCPN version 2.5. Not yet ried the Oesenc charts with the dongle.

Bram
Reply
#16
(2020-10-13, 10:47 PM)verkerkbr Wrote: Now tried the Groovy Gorilla on the Raspberry Pi4. This also works with OpenCPN version 2.5. Not yet ried the Oesenc charts with the dongle.

Bram

The Ubuntu Groovy Gorilla 64 bits also works with the Oesenc dongle on the RPI 4.Next will be adding the OpenPlotter add-ons.

Important is the adding of the libusb support. Otherwise it does not work. And you need the right Oesenc plugin.


Bram
Reply
#17
Tried to install the OpenPlotter add-ons on the Groovy Gorilla. However that does not works.

The OpenPlotter settings item did not start. So it is impossible to install the other "goodies".

OpenCPN and Oesenc is working very well and fast. With a nice interface. Kernel version is 4.8.

Bram
Reply
#18
(2020-10-15, 03:03 PM)verkerkbr Wrote: Tried to install the OpenPlotter add-ons on the Groovy Gorilla. However that does not works.

The OpenPlotter settings item did not start. So it is impossible to install the other "goodies".

OpenCPN and Oesenc is working very well and fast. With a nice interface. Kernel version is 4.8.

Bram

For your information of what is different in Groovy Gorilla on the RPI4 .

I can send a copy of the error message when starting openplotter-settings from the terminal.

Bram
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)