This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Thread Rating:
  • 1 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
New OpenPlotter GPIO app available
#21
I have installed this latest version & configured my 1w sensors but I must be doing something wrong. Could you please run through the process I should be doing because I am getting the following error. Should this be set to "read only" or "read write"??

   

   
Reply
#22
You have to set your 1W sensors only in the 1W tab and enable read/write permission in Signal k server when required.
Unless you are conecting a seatalk 1 device, remove and disable anythink in seatal 1 tab.
Reply
#23
I should mention before I got the above error I had this " 1 needs authentication"error first so I added the 1w connection

   
Reply
#24
The ws connection is for any device using the GPIO app (1W, digital, pulse) and it should be aproved just once. Seatalk1 has its own connection.
To aprove the ws access go to "signal k - security - Access requests". Once approved this access should appear in "signal k - security - Devices".
Read the messages you will get in the openplotter-gpio app and you will be guided.
Reply
#25
(2021-01-17, 09:48 PM)Sailoog Wrote: You have to set your 1W sensors only in the 1W tab and enable read/write permission in Signal k server when required.
Unless you are conecting a seatalk 1 device, remove and disable anythink in seatal 1 tab.

I don't have anything in the seatalk 1 tab

   

   
Reply
#26
what happens if you press "refresh"?
Reply
#27
(2021-01-17, 09:58 PM)Sailoog Wrote: what happens if you press "refresh"?

I get this message:

   


I hit Allowed Devices which takes me to the Devices page which shows no devices but then if I hit the Devices tab I get my device showing:

   
Reply
#28
Click on your device and set read/write instead of just read
Reply
#29
(2021-01-17, 10:32 PM)Sailoog Wrote: Click on your device and set read/write instead of just read

Excellent!!

All working great now once set to read/write. 

I was getting a warning in the "Check System" as well until I did this.

Thanks very much for all your hard work Sailoog!!

All I need now is to be able to put alarms etc with these when the IOT app is here and I'll be an extreeeeemly happy chappy Smile
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)