This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
another beta image release
(2020-11-06, 10:31 PM)rastam4n Wrote: So I was out all day today testing the new beta image with Tiny pilot and the pypilot plugin from git.  Works very well and did not disconnect once
Then I tried the Openplotter pypilot app which I installed from git and while it worked just as well none of the configuration/calibration and gains were not visible from the pypilot plugin. The menus would open but they were empty windows.   I was able to make changes but I had to use the web app.  
Once configured it worked great but it would be nice to be able to make changes from within the opencpn plugin
maybe it helps to find the error, 
if I reinstall the pypilot plugin in the plugin directory of OpenCPN, the gains and windows can be seen again. 
I have another problem when I switch from active to inactive in the webapp and in the pypilot plugin of OpenCPN, the motor moves. 
That doesn't happen with the GIPO keys, maybe someone has the same problem.

I just fixed the gains problem yesterday. It was an issue if opencpn was started before pypilot, so restarting opencpn fixed it.

So when you deactivate the autopilot the motor moves? Does it just move a little?
(2020-11-07, 02:48 PM)seandepagnier Wrote: I just fixed the gains problem yesterday.   It was an issue if opencpn was started before pypilot, so restarting opencpn fixed it.

So when you deactivate the autopilot the motor moves?   Does it just move a little?
Yes, it only moves a little but only when I deactivate it via the webapp or pypilot_ plugin. 
If I deactivate via gipo pin then everything is perfect.

ok i'll try to replicate it, thanks for reporting
Another 6 hours of trolling around the Great Lakes fishing. Not one error, disconnection or any problems. This latest beta image and openCPN plugin is a winner in my opinion
Great work Sean. I really value the reliability of this version.

I finished my test setup today (I had to wait for a working IBT2-bridge cause the first one I got was broken).


Raspberry Pi Zero w with Tinypilot image 2020-10-27 via UART connected with
Arduino Nano with the motor.ino from Timo (Code) modified for using Pins 9 and 10 for PWM for changing PWM frequency.
IBT2_bridge as H-Bridge Motor-Controler
Linear-Aktuator with Rudderfeedback from here.
IMU 9250 connected via I2C with the Pi

Raspberry Pi 3b+ with latest Raspbian Buster
Opencpn (not Openplotter) 5.2.4 from repo
pypilot plugin from repo

Tinypilot is wlan client of the Rpi3b+, Data connections via plugin and tcp 

Just simulated boat moving here at home on the table.

All values from the Tinypilot are correct transmitted to the plugin in opencpn. It´s possible to see them in the settings windows and the values seems to be correct. 

AP disengaged: Plugin Funktion-knobs working, Hardware (via GPIO) changings working, web-gui changings working.
Aktuator moves like expected

AP engaged tested (only compass mode): generally the Funktion knobs worked like in disengaged mode. Moving the IMU ends in moving Aktuator mostly as expected. I had to play around with the gain settings until i got an acceptable response. Sometimes the heading values from the IMU were strange incorrect and this ends in sometimes not logical movements of the actuator. But this is due to the not yet found smooth point for the gains I think and also the simulated movement of the IMU here on the table (I didn´t get a good calibration, I move the IMU slowly in circles but this was not very successfully.

Tacking: When pressing the knop in the plugin (compass mode) the waiting time counts down and then the AP just disengaged, no movement of the actuator.
When using the GPIO26 Hardware Tacking input nothing happens.
I know, that tacking function not really implemented but is this normal?

When using the eg. the +10 knob and pressing it for 10 times (tack angel 100°) then the Aktuator moves as expected and changes the course like expected but not very fast (maybe due to the gain settings). On the other hand it´s normal for the pid that only big differences between actual and target heading ends in big movements of the actuator.

Sometimes the gain-settings are not visible when starting Opencpn and / or pypilot. Mostly they came back when restarting opencpn.
When not visible then also a lot of the other setting values under the "settings windows" are not shown.
Sometimes the gain-settings are invisible after done some actions in the plugin. Didn´t found out yet witch actions ends in the invisible gain-setting window (and other invisible setting-informations).   

Tried to built pypilot plugin from source. This was ok but then I failed to install it. I get in struggle with the plugin management from opencpn.
I´ll investigate this in the next few weeks.

Thank you Sean for your work. Seems that this AP works better than my old Raymarine ST 2000 when use the right gain settings.

Wishlist (if I may place a wish Blush ): Working tack function. When sailing single handed I use the tack function from the ST 2000 very often so a working tack function will be fine.

Now I´m waiting for some custom made pcbs, for some touch sensors and a lcd (the jlx12864) witch I want to connect then with the Pi zero.

Best regards

don't expect the tacking function to work well, I have too many things on my list before and I never managed to revisit it

As for the plugin gains issue, I recently fixed if you can recompile the plugin

Sean, thanks for your explanation.

You wrote it before that the tacking function is not very well implemented I know.

I wonder that, with the latest tinypilot image, the engaged AP just disengaged after the waiting time was count down.
I expected that something happens like moving the actuator but when you say this is normal than I try to use the heading changing knobs in the future.

I tried to recompile the plugin, this was successful but then I get in struggle with OCs plugin manager and I didn´t get it installed in OC.

Best regards

Did you also compile opencpn from git? I think it fixed this problem also recently
Hi Sean,

no, I used the ready build version from repo.
Building OC from git is also an option but this is the last way cause this ends in some more work around my OC setup. First I´ll try to understand why I can´t install the plugin as expected.

Thanks and kind regards


Forum Jump:

Users browsing this thread: 1 Guest(s)