This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Problem after Signal K update geting Tinypilot connected
today i updated the latest signalk.
It is now 1.36.0
Now tinypilot is not able to establish signalk connection.
I see in the dashboard te ws.pypilot-3133xxxxx
coming up for 0.4 - 0.6  with a little yellow line but imediatly looses it.
If i deleete the device in security, i get a new device request. I accept it with read/write. And in the security
settings y have untaged the read only ...
also restarting signalk, rebooting the pi and the TP gave no success.
so i guess it is a problem with registering the device but i don,t understand much about signalk.

It is not a big thing as i can go back to a tcp connection.
But maybe someone can solve it.
Save sailing
moved to pypilot forum
I went back to signalk server version 1.35.2.
Here erverything is working fine.
Save sailing
Sean: what http endpoints does Pypilot use? Some of the server-specific ones (not under /signalk prefix) were moved under /skServer. We can add backwards compatibility so that they are accessible in the previous location, but would like to keep that to a minimum.
it uses zeroconf to find signalk with ServiceBrowser(zeroconf, "_http._tcp.local.", listener)

Then (from
r = requests.get('http://' + self.signalk_host_port + '/signalk')
contents = pyjson.loads(r.content)
self.signalk_ws_url = contents['endpoints']['v1']['signalk-ws'] + '?subscribe=none'

Does this answer the question of why it doesn't work? It would be great to fix this quickly, thanks for checking in here.
maybe also the information helps that I run OP as access point
and TP as client with the fix IP not DHCP.
Thanks - none of that is changed.

Anybody else having trouble with 1.36.0?
After above post I tried to connect with signalk 1.36.0.

I found a pypilot in the security settings.
I enabled it, but it did not work like in the OP's case
After, I removed the connection, there has been no new attempt te connect and I switched back to NMEA0183.

I'm not familiar with SignalK enough to know where to search for extra information.

From my point of view zeroconf is totally unreliable since I don't know how to trigger a request.
If I miss the automated request I can't find anything in the logfiles.
I do understand that main part of the problem is a lack in understanding of how it works from my side.
The offending message (below) indeed seems to be a new signalk construct; I cannot find it in the old signalk specs. It is this construct that knocks off pypilot; in an 'update', it expects a 'values' item, not a 'meta'. I'll check with the signalk forum whether these messages can be switched off or someting - will report back.

{'context': 'vessels.urn:mrn:signalk:uuid:d54ef29f-701a-443c-9c18-a7fb3d4e171f',
   [{'timestamp': '2020-12-29T18:22:48.949Z',
       [{'path': 'environment.wind.speedApparent',
            {'units': 'm/s',
             'description': 'Apparent wind speed'}}
I will debug... and also to fix pypilot to not crash no matter what signalk sends it... I pushed a simple change but I have not yet tried out the latest signalk server, so I hope it works with meta now as well as ignore signalk messages it can't understand.

Forum Jump:

Users browsing this thread: 1 Guest(s)