This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
LCD Display
#31
(2021-04-02, 01:43 AM)seandepagnier Wrote: you would have to write a driver for it

Understood Sean, thanks for the replay. 

probably I will buy the Nokia/jlx12864 to keep the autopilot proyect going. and I will try to find or learn how to write the driver for the 320x240 2'2" screen, in orther to have a bit bigger screen.  I have been reading about fbcp-ili9341 controler. But I am still begginer and learning. 

regards. 
Reply
#32
if you can get it working with fbtft linux framebuffer driver ican work.

I'm using that controller on the esp32, so I have written a driver for it to use esp32 as a remote control, but didn't try on the pi.
Reply
#33
   
hi, 
today I have been trying to "clone" the driver either  fbcp-ili9341 & fbtft (I found in github forum)in to the tinypilot / piCore. 
it is what I have done, from my zero knowledge (I Dont know how to communicate raspberry picore form my laptop):

1- Connecting the raspberry to my wifi (my smartphone as hotspot). sudo wifi.sh 
it was sucsesfull.
once connected to the wifi,
2- I have follow the next:

sudo apt-get install cmake
cd ~
git clone https://github.com/juj/fbcp-ili9341.git
cd fbcp-ili9341
mkdir build
cd build
cmake [options] ..
make -j
sudo ./fbcp-ili9341



"sudo apt-get install cmake", piCore says that command not found.

any way I kept going writing the command to clone the driver

"git clone https://github.com/juj/fbcp-ili9341.git"
but piCore says unable to find remote helper for https.

is it totally wrong what I am doing?? 
How could I clone or install the driver to the picore then??

thanks for the help 
regards,
Reply
#34
try 

Code:
git clone git://github.com/juj/fbcp-ili9341.git

that is, replace https:// with git://
For more details about packages on tinycore linux, check out https://github.com/pypilotWorkbook/workb...r-the-hood



the cmake package is available on the tinypilot image. On tinycore linux, you don't install it, but you 'load' it:

Code:
tc@box:~$ tce-load -i cmake
cmake.tcz: OK
tc@box:~$ which cmake
/usr/local/bin/cmake

Good luck with compiling your driver! I reckon you have to make a .tcz package out of it. An example of this you can find in pypilot.build.


Attached Files
.txt   tinypilot-git-clone.txt (Size: 3.38 KB / Downloads: 11)
Reply
#35
    hi,

thanks for the help Ironman. 

I think I could instal the driver.
I got the configuring errors , as you got in the attachment log.

CMake Error at CMakeLists.txt:136 (message):
 Please define -DSPI_BUS_CLOCK_DIVISOR=<some even number> on the CMake
 command line! (see files ili9341.h/waveshare35b.h for details) This
 parameter along with core_freq=xxx in /boot/config.txt defines the SPI
 display speed.  Smaller divisor number=faster speed, higher number=slower.
-- Configuring incomplete, errors occurred!
See also "/home/tc/fbcp-ili9341/build/CMakeFiles/CMakeOutput.log".


So after adjusting the "-DSPI_BUS_CLOCK_DIVISOR=40" apparently I didnt have configuring errors.
I wrote the command "sudo cmake -DILI9341=ON .."
So I got;
- Configuring done
- generating done.
- build files have been written to: home/tc/fbcp-ili9341/build


apparently looking fine, but from here, I dont know how to continue.

I have been checking the pypilot.build and the "tinypilot under the hood" workbook that you sugested, to get more info and understanding. but still far from my knowledge. Confused  

I will keep researching
Reply
#36
don't you just type "make" at that point?
Reply
#37
   

hi Sean,

Yes, I have just tried, and getting the errors of the photo...
I have been researching in some webs how to solve it. But I dont find the answer.

thanks
Reply
#38
If you did 'sudo cmake', you should now do 'sudo make' as well.

Sudo runs the command as root, so the directories created are owned by root. If you are not root, you get a permission denied when you want to write to it.
Reply
#39
maybe first

chown -R pi *
Reply
#40
(2021-04-11, 03:55 PM)seandepagnier Wrote: maybe first

chown -R pi *

Also good option, but tinypilot does not have a pi user I believe, so make that chmod -R tc *
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)