This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Most basic Q: installing - NUC w/ Mint
#1
I installed OP on a RPI a few years ago, but now have a new NUC 10i7 as the boat computer running lunux mint. I am a NOOBey on linux, so I am handicapped from the getgo. I have installed the "settings 2.5.0", but how to get all packages installed is lost in the documentation or lack of. Some of the forum advice points to documentation on gitbook which only opens gitbook home page. I created an account, but still link only opens home page. Documentation is blank for packages on OPlotter. No joy.
In settings, all package candidates are listed on only settings is installed.
INSTALL only lists command options.
ADD SOURCES says all sources good
What do i need to install packages?
Do I need to follow the basic instructions to install image or noob on a SD card and boot from it?
The advanced seem to say all can be done from SETTINGS install. There may be a thread on this, but I didn't find it.

Thanks
Reply
#2
Openplotter does work on a PC. https://www.youtube.com/watch?v=z3bA69LPeEY
Reply
#3
(2020-11-19, 11:01 PM)e-sailing Wrote: Openplotter does work on a PC. https://www.youtube.com/watch?v=z3bA69LPeEY

Thanks for youtube link, but he fly's through the steps. Also it is windows PC centric and I am using linux mint. The RUFUS bootable USB tool is windows only. I will look for linux tool and go from there. But..anyone have steps for getting SETTINGS to see source files in a linux environment?
Reply
#4
after adding sources click on "update candidates". what happens?
Reply
#5
Adding sources is a mystery. It doesn't ask for any directory. I assume it works on the settings.deb.  Update candidate as well as "install all from available updates" just shows syntax usage for apt: "Usage: apt command [options]".
Reply
#6
you are right, there is something strange. I have just tried to install any app from openplotter-settings and you get that apt command help. I am using Linux Mint Ulyana that is based on Ubuntu Focal and only works in Ubuntu Focal, investigating...
Reply
#7
damn now i have to get a second atomicpi to play with.Smile i am using one for a plex server with ubuntu 20.04. it only has 2Gb ram though. i still like it for the price.
i think i can add a pi zero as a USB Gadget for easier gpio access
i had problems installing apps too, on it. thats why it became a plex server.
les noble i just use "disks" on linux and restore image to a usb drive and install from it instead of rufus.. if you have a problem with mbr use gparted to create a partition table on the usb first and format to fat32.
mare liberum
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)