This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Signal K issue
Hi everyone,

I just updated my OpenPlotter to version 2.

First is there a documenation about the signal K serveur ? I found the API documentation here, but nothing about the serveur.

So i have some questions. I struggle with the connections between OpenCPN and SignalK and i cannot make it work as described in the OpenPlotter documentation here

In the data connection section :
  • what is the meaning of "Sentence Event" and what is the purpose ?
  • "Ignored Sentences". That one is clear for me and my tests. The NMEA Phrases that are in this field will not be considerd by signal K and not in the list of the data browser.
  • How can i set a connection in Signal K to send data ?
If i am folowing the OpenPlotter documentatio, then with OpenCPN i send via UDP RMB and APB, then in the signal K data connection, i ignore RMB and APB to avoid loops in the systeme. Resulting Signal get Nothing ! so how can you send something to your USB rs 422 device ?

Of course signal K is sending, all his data to OpenCPN including RMB and APB if not filtered. Then OpenCPN is freezing, that happened to me many times. (I had to delete by hand the conection in the /home/pi/.opencpnopencpn.conf to laucnh it again.

Is there a solution to filter signal K output data from the server ?

I spent hours arround this topic, at this time Only the solution below is working. I have to set signal K input in OpenCPN to priority 2 to avoid confilcts or worse carsh..

[Image: Shema-flux-GPS-via-Open-CPN.png]
Outputting data seems to be real stumbling block. I tried to make things a little clearer:

There's also
(2020-12-27, 08:17 PM)tkurki Wrote: Outputting data seems to be real stumbling block. I tried to make things a little clearer:

There's also

Tks for the links it's useful and help a lot to understant.

I have been able to plug my USB RS 422 device to feed the VHF radio first with OpenCPN and finlaly with Signal K also

With Signal K i did :
  • Enable convert signal K to NMEA0183 plugin, check GGA
  • New serial connection with  Data type : NMEA, Output Events : nmea0183out
The red led of the USB device is blinking and the VHF get the signal properly, so evrything is fine.

Forum Jump:

Users browsing this thread: 1 Guest(s)