This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Autopilot_route plugin and pypilot
Just to share something I found out, and to (re)kindle interest in the OpenCPN autopilot_route plugin: When using the OpenCPN route/track function, the pypilot option 'gps' lights up by default, provided you set up a connection on tcp/20220 to pypilot. However, when using the autopilot_route plugin, pypilot does not show the gps option by default. The solution to this is to add RMC messages to the NMEA output in the plugin preferences (see image below). By default, the NMEA output is limited to APB messages only.

It took me hours to figure this out, only after tracing large parts of the pypilot code. The moment I realised I knew I had read it somewhere.

The GPS option in the pypilot interfaces only seems to light up when RMC messages are provided. The pypilot, however, only seems to use the content of the APB messages for following a track (XTE and BRG). This seems a bit weird, because XTE is in RMB messages and not in RMC messages. The OpenCPN route/track option provides RMB, RMC and APB messages by default.

Attached Files Image(s)
I did not know this, so I'm confused by your finding. Normally only APB is needed in the plugin, and the other options are to be complete and output everything the internal route logic allows.

Normally opencpn itself forwards the the RMC messages, so it should not depend on the plugin. Are you sure the connection to 20220 is set to output on that port, and gps is received? I would check the opencpn nmea debugger and compare it with and without the autopilot route plugin enabled.

So to confirm, the RMC messages are sent when the plugin is disabled, but they are not sent when it is enabled unless checked in the plugin preferences? This seems wrong to me.

I will be sure to look for this when I get the chance to run more extensive tests of the autopilot route plugin.
I should have mentioned that I'm getting the data from signalk now, so there's no nmea messages going into opencpn that can be forwarded.

Forum Jump:

Users browsing this thread: 1 Guest(s)