This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Webapp - No connection (newest op image)
Hi Sean when I try git pull I am getting Fatal: Not a git repository (or any of the parent directories) .git .  I went back in and cleaned out the old files and it is still not allowing the git pull sorry about this I am still a novice
well it sounds corrupted try:

rm -rf pypilot
git clone
(2021-07-27, 01:52 AM)seandepagnier Wrote: well it sounds corrupted try:

rm -rf pypilot
git clone

So this is interesting, I did that prior to your suggestion, but it gave me the same error, I tried a completely fresh install this morning and I am coming up with the same thing.
please post the terminal output. Your error is technically impossible
(2021-07-27, 08:07 PM)seandepagnier Wrote: please post the terminal output.   Your error is technically impossible

You are correct!!! I made the mistake in my haste after a fresh install I put git pull instead of git clone.  Got it all installed tonight and tested in the slip, everything is working well.  Will take it out later this week for a test in the Bay.  Thank you for your patience and all of your help.
I wanted to provide a quick update on this. I initially installed a pican-m board, and set up the can bus first, and then tried to install pypilot. When I started from scratch without the pican-m and ran the setup there were no issues and pypilot works great. Last night I started fresh with another sd card and set up the pican-m and can bus, and the issue was created again. Ultimately I will run a two pi setup with a signalk server feeding data, I just wanted to see if there were any other related issues with this setup. The issue with doing this was two parts, the first is the IMU is not recognized in pypilot (probably due to the sharing of pins), and secondly, the pypilot server will not connect.
You will have to consider the hardware differences as well as software of what you are running. I cannot debug every hardware configuration, but if as you say the pins are conflicting then this is an obvious issue. Of course using multiple pi is possible easy way to avoid these issues. The pi zero w with tinycore is very stable with tinypilot so maybe this is a good option.

Forum Jump:

Users browsing this thread: 1 Guest(s)