This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Pypilot/openplotter/raspios_arm64
#1
Cannot install, under raspbian arm64, PyPilot with openplotter: "openplotter-pypilot: Depends: python3-flask-socketio but it is not installable"
help
Reply
#2
not an expert in Debian packages, but it doesn't look like it's available in Buster it's in Sid (unstable and Bullseye (testing) though

you could try and download it from here https://pkgs.org/download/python3-flask-socketio & install with dpkg

(This might be wrong though ... I'm an Arch user and having to learn Debian for all of this (OpenCPN etc) ....)
Reply
#3
Here is a script to install pypilot
(Works on arm64 and armhf).

I use it building BBN OS image.

It will not run for you as is
but you can use it as a reference.

https://github.com/bareboat-necessities/...pypilot.sh
Download BBN Marine OS for raspberry pi 

https://bareboat-necessities.github.io/m...at-os.html
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)