This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
... pipe a NMEA Script from Garmin GND10 using FDX -> NMEA into openplotter
my Boat gets a new Garmin G Sail Pack.
Included in the Garmin Pack is a "BlackBox" GND 10 which translates between the propretary Nexus Network Protokoll FDX and N2K.
The GND10 has also a MiniUSB Port to connect a Windows PC to run the Nexus Race analysis Software an to calibrate the transducer's or other navigation Software.
So i tried to read the serial Stream that comes out of it in hope it is NMEA, but it wasnt.
I search and foud a cool norwegian man that tried succesfully to figure out what come's out of the Miniusb Port

after a while and a little issue with the script's off Lasse i get it also to run.
using a new Input in OpenCPN and netcat using the following piped call:
/home/pi/GND10read/ | /home/pi/GND10read/ | /home/pi/GND10read/ |nc -u 1234

But i am not able to pipe it directly into KPLEX or SignalK what schould be better.

I also get a hint from Tkurki from the SignalK Slack "forum" to pipe the script into a piped provider off the signalK node server config, what also dont run.
i attached my config try for configure a piped executer.

i am so hopefully that anyone can help me.

Attached Files
.txt   openplotter-settings.json.txt (Size: 2.08 KB / Downloads: 12)
With the last versions of fdxread and openplotter/alpha, I tried :

fdxread ~/fdxread/dumps/onsdagsregatta-2016-08-17.dump | nc -u localhost 10110

and it works and is visible in NMEA diagnostic

I must work with USB
fdxread /dev/ttyOP_FDX | nc -u localhost 10110
(ttyOP_FDX is a name created wit USB manager)

I plan to do about the same thing as you tried.
In fact I have no GND10 but a WSI box.
I plan and HOPE to :
- connect my RPI3 with an USB RS485 cable on the yellow/white of the Nexus network
- use fdxread to translate FDX protocol into NMEA or SIGNALK
- add a tool into openplotter to have fdxread in the Tools menu

I will work on it next weeks ....
I have just written a first version for an openplotter tool for fdxread :

To try it : 
- copy the file into your tools directory
- copy the test dump file onsdagsregatta-2016-08-17.dump on your Desktop
- modify the Tools section in the openplotter.conf file to add the fdxread entry (cf. documentation)
- deconnect your GPS,...
- run the signalk diagnostic first and run Tools/fdxread to see the simulation result

After you can replace in the file, the input file with your USB tty (in my case I use the stable name /dev/ttyOP_FDX)

If it can helps you.
ygageot have you written a tool for OP? that is amazing, if you want to add this tool to the source please guide me to do it because I know nothing about fdxread or GND10
Maybe you can push the code to github?
(2017-05-16, 06:11 PM)Sailoog Wrote: ygageot have you written a tool for OP? that is amazing, if you want to add this tool to the source please guide me to do it because I know nothing about fdxread or GND10
Maybe you can push the code to github?
fdxread is a GitHub project from Lasse Karstensen.

The goal of the software is to connect and parse the private Nexus network protocol called FDX.
This protocol was used for Silva -> Nexus -> Garmin NX and NX2 equipments.
NX Wind, NX server, NX sea, gWind,...

Lasse try to connect Garmin GND10, equipment connected to FDX Network bus but with an USB port with FDX protocol.
In my case I try, without GND10 equipment to connect directly my RPI3 with a RS485 interface to integrate data from wind, depth, loch with Lasse parser.

The Lasse software is in development because it is very difficult to discover an unknown binary & private protocol.

I developed quickly a first tool version to integrate FDX.

I need to have a better tool with stop.

I dont know if it is better to have a configuration file with only one simple parameter "input" with a default /dev/ttyOP_FDX or to oblige to use only name /dev/ttyOP_FDX for the USB port without configuration ???

When it will be more stable, I will push the module.

Future : It can be useful to have a global GUI panel to choose effective external tools
Nice! thanks.

You can add to openplotter.conf:

device =

and force to ttyOP_FDX in autosetup
Hej @Ygageot.
How is your stand in the project? I have not used Open Plotter so much the last year, but I'd like to breathe in the built-in Pi again. At the moment I'm struggling to get the GND up and running again. Can you send me the file again?

Forum Jump:

Users browsing this thread: 1 Guest(s)