This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Tinypilot boot failure on pypilot hat with Nokia display
Having had difficulties using the Pypilot Hat that I purchased last year and installed on a Rasberry Pi 3b+ with openplotter, I decided to give Tinypilot a try.  I purchased a Zero W and installed the hat.  I first loaded the recent version of Tinypilot (tinypilot_21122019.img.xz) from the website.  The system began its boot process and stopped mid way.  I then figured that since my hat is becoming a bit dated, I should try the earlier version tinypilot_21122019.img).  It also stopped mid way in the boot process. 

I got the same errors with both versions.  I couldn't copy it because I was using the Pi and I am using my laptop now.  Basically, I got the following errors:

insmod: can't insert 'mnt/nmcblk0p2/tinypilot/modules/v7_modules/rc-core.ko
invalid module format

The same string was repeated for lirc-dev.ko and lirc.rpi.ko.

Also got SIOCGIFFLAGS: No such device cannot open shared object file. No such file or directory

On the Nokia display it started with the Pypilot 0.12 screen
Connect to server 318
Warning: No motor controller (Motor controller is attached) also had WIFI
Error: Compass or gyro error

On my earlier posts I was having trouble with the Nokia display.  Now it appears that the Nokia display is working okay but the tinypilot isn't.  I tried loading the sd card using the imager and using the dd command with the same results.
Well, non of the console messages are "errors" only warnings.

As for the gyro or compass error. Could you please show a picture of your setup? Maybe it is connected wrong. It seems the inertial sensors are not detected.

As for motor controller, also the same. Ensure the controller is powered. There is normally no special configuration needed. The newest image should work with the older hardware as well. If you did get bad hardware from me for some reason, I will replace it.
Well, I rebooted the unit again this morning and got almost the same result but this time the display continued to display the main screen.  The terminal window showed pretty much the same stuff as before but one of the previous messages was not displayed and it didn't go to the no gyro message display.  I decided to check if I could see it on my laptop.  I checked for pypilot as a wifi connection and it was there.  I logged on and then ran the in my browser and got the pypilot control window.  So, it appears to work now.  I also was able to get it on my cell phone: nice!

When you look at the terminal output, does it look right?  I guess I was expecting this to work differently.  I have been using a display, mouse and keyboard on the same computer as pypilot instead of using it headless (a strange concept when you are not used to it) and I have been expecting it to have a GUI or main screen come up. 

I do have the motor attached to the pypilot computer but not to a motor or 12v power supply.  Does that make it apper as though it is not connected?

The motor controller must have 12 volt power to be able to work because there is optical isolation. So without power to the controller there is no communication. Ensure the red light on the controller is on to know it is powered.

As for the terminal, yes everything is normal. There are a few warnings that should be suppressed but I never bothered since few users use an hdmi display. The hdmi would be useful mainly for debugging, and at that only for debugging networking. Otherwise I simply use ssh to connect.

It would be possible to display what is shown on the lcd also on hdmi but I am not sure if that is useful. As for gui etc.. if you really want this I suggest just using openplotter or another distro as for now, there is no graphical interface on the tinypilot.

Not sure about your gyro error message, but if it went away likely the connections were poor. Would be interested to know if you find this problem again, or if you can check the pins are clean on the pi if it happens.

Suggest you try the newer image, and check back soon for the next release.
I think I just fried the display. I accidentally plugged the power into the usb connector. No info displayed. The wifi still comes up.
You can apply power to either usb port. Do you mean you used the data port?

Try pushing on the metal tab on the display.
I plugged the power supply cord into the connector marked USB.
That will work fine, just you won't be able to put any usb device if you do that.

Power can work on either port. Only the left port works fro data.
I cleaned the pins on the display and it works again.

Forum Jump:

Users browsing this thread: 1 Guest(s)