This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
installing from openplotter-settings_2.8.1-stable_all.deb
Trying to install onto latest raspberry pi OS, installed the settings deb which worked ok & updated sources, running network from the settings open button I'm getting this, any ideas? Ta
pi@raspberrypi:~ $ sudo openplotter-settings
wrong external apps format: unexpected EOF while parsing (<string>, line 0)
wrong external apps format: unexpected EOF while parsing (<string>, line 0)
Traceback (most recent call last):
 File "/usr/bin/openplotter-network", line 11, in <module>
   load_entry_point('openplotterNetwork==2.1.5', 'console_scripts', 'openplotter-network')()
 File "/usr/lib/python3/dist-packages/openplotterNetwork/", line 725, in main
 File "/usr/lib/python3/dist-packages/openplotterNetwork/", line 29, in __init__
   import pyric.pyw as pyw
ModuleNotFoundError: No module named 'pyric'
Same running settings without sudo.

pip3 install PyRIC
Seems to have solved it.
pyric is already installed after openplotter-network app installation:

Maybe something failed during your installation and you did not detect it. Let's se if somebody reports the same issue.

Forum Jump:

Users browsing this thread: 1 Guest(s)