This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
How to ssh pypilot through ethernet
(2021-10-22, 01:19 AM)seandepagnier Wrote: Some data seems corrupted.    Can you try downloading the sd card image again, and writing it to a different card?

I did that already, i downloaded the image file from another pc and wrote it on a brand new 32 Gb sd card and got the same results.
It seems hostadp is missing, i checked and indeed the file is not present in the /run directory. Can i find somewhere a proper hostadp file and patch it?

Also when i open the formatted sd card with gparted twp error messages pop up something like "data cannot be out of logical volume" i mention it just in case it may have to do with my problem. EDIT: this is not true anymore.

I tried again with a new sd card using the xzcat command instead of Raspberry imager or nautilus and got the same results, no WIFI and identical current log file.
If the file is missing how are you able to start hostapd at all? Which image file exactly? What do you get for:

md5sum tinypilot_2020_10_27.img
a334048d270029bba32c6678a06a6ec5 tinypilot_2020_10_27.img

Does it match?
(2021-10-22, 04:47 PM)seandepagnier Wrote: If the file is missing how are you able to start hostapd at all?   Which image file exactly?   What do you get for:

md5sum tinypilot_2020_10_27.img
a334048d270029bba32c6678a06a6ec5  tinypilot_2020_10_27.img

Does it match?

I cannot answer to your first question, I just know I can activate the WIFI once I am able to use the Pypilot browser interface when the RPi is hooked to my PC with the ethernet cable.

My checksum returns:
md5sum tinypilot_2020_10_27.img
aff3a95f2930baf1176ad21f3f55ac7d  tinypilot_2020_10_27.img I downloaded from

EDIT: I redownloaded and got the same checksum
md5sum tinypilot_2020_10_27.img
aff3a95f2930baf1176ad21f3f55ac7d tinypilot_2020_10_27.img
my local copy had some slight tweaks which explains the different checksum.

I don't understand how the file is missing, and I know this image has been used in lots of cases.

Is there any chance you can try with a pi zero w and compare the difference?
I don't have pi zero w sorry, i'd like to mention also two points which might be useful:
1 - i also noticed that if i change the field "magnetic heading offset" in the calibration menu of the browser interface the new value is not taken into account and is reset to -90 which for some reason must be the default value
2 - i first tried the pypilot hat with an old pi B+ which had no embeded wifi, i tried a wifi dongle and gave up after a while. Since then of course i have reformatted and reburned different sd cards with the tinypilot image here above to run a brand new Rpi 3B so there should be no traces left from my previous tries with the old rpi but who knows?
As of now i can use my pypilot as is, i just never shut it down (but i can shut down the motor controller).
The magnetic offset is a bug in that version which is since corrected. It will be fixed in the next version.

You can still change it through other interfaces just not the browser.
Ok, i edited the pypilot.conf file and i am good to go. Thank you for your help.

Forum Jump:

Users browsing this thread: 1 Guest(s)