This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[SOLVED] Can't "Engaged" Arduino
(2021-11-03, 08:30 AM)ironman Wrote: Can't download the image yet, but I sent you an access request.

"Request Sent. You'll get an email letting you know if the file is shared with you"

Request accepted. Thank you
Ok! Got it.

First, and this is for everyone useful to know, with your image the RX led on the arduino was constantly ON. That denotes a fault in /boot/config.txt. I compared it to mine, changed one line, then rebooted:


The RX led was now OFF. (Note: GPIO14 = the TX signal, to which the arduino's RX is connected; if you want to use the gpio-fan overlay you'd need to use another pin)

Then, in the log I could not see a line saying servo probe, so I removed an empty file .pypilot/serial. And now it works; lights are blinking:

   servo probe ('/dev/ttyAMA0', 38400) 156.022047648
   arduino servo found ['/dev/ttyAMA0', 38400]

Note, that I ran pypilot at the prompt. This is the best way to get useful feedback.

Let me know if this works on your end as well.


PS the overlay name pi3-disable-bt appears to have been renamed to disable-bt, but is still available for backward compatibility. They both work on my pi4. I made a few edits to the previous post to prevent ambiguity in the future.
Thank you very much!

I have followed your instructions and obtained the same results.

It is working fine. Great job!

Thanks a lot a both of you.



Forum Jump:

Users browsing this thread: 1 Guest(s)