This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Getting nmea data out of Signal K/OpenCPN
#1
Good day, 

I have successfuly connected a multiplexer (Yakmux) to my Rpi4 running Openplotter/Signal K.  I now receive data from my nmea0183 instruments and my GPS antenna (both wired to the multiplexer).

I now want to output nmea data in 2 ways:

1. Send GPS sentences to my VHF radio

2. Send relevant sentences to my autopilot (back up through the multiplexer and into the nmea network)



I've researched this, followed many of the threads here and given it a go.  The GPS to VHF issue was an easier place to start, so that's where I've spent my time.  Alas it's not working.

Instead of posting a lot of screenshots, what information do you folks need to help me?  I essentially created a connection in Openplotter, then added to Signal K.  I downloaded nmea0183-nmea0183 app...followed the recipe...nope...

I took screenshots of everything, please advise...thank you very much.
Reply
#2
Openplotter connections:

1.
Network
Input
SignalK
localhost
3000
Priority 1

2.
Network
Output
UDP
0.0.0.0
10119
Priority 1

"opencpnout"
output on this port
filter RMB,APB



SignalK

1.
Yakmux (multiplexer)
nmea0183
serial
/dev/ttyOP_yakmux
4800baud
events vhf,nmea0183out
ignore RMB, APB

2.
Opencpnout
nmea0183
UDP
10119
ignore RMB, APB

3.
vhfout
nmea0183
serial
/dev/ttyOP_vhfout
4800baud
event vhf


nmea0183-nmea0183 app

input nmea0183out
output vhf
GGA, GLL, GNS ticked

error in data log

"signalk to nmea GGA no position, not converting"
Reply
#3
how is the VHF connected to the system? if you connect it to the Yakmux it will get the GPS signals directly from the GPS?
Reply
#4
(2021-10-28, 03:09 AM)Techstyle Wrote: how is the VHF connected to the system? if you connect it to the Yakmux it will get the GPS signals directly from the GPS?

Ive connected the vhf to the Rpi with a RS485 serial usb cable.  I was concerned about sending ALL nmea data to the vhf if I connected it directly to the Yakmux, and I wasn't sure the Yakmux shared data coming in on one port to a device on another port.  I also wasn't sure joining the leads at the Yak would work (ie. physically connecting the leads at the Yak)
Reply
#5
(2021-10-28, 10:43 PM)Island_Moose Wrote:
(2021-10-28, 03:09 AM)Techstyle Wrote: how is the VHF connected to the system? if you connect it to the Yakmux it will get the GPS signals directly from the GPS?

Ive connected the vhf to the Rpi with a RS485 serial usb cable.  I was concerned about sending ALL nmea data to the vhf if I connected it directly to the Yakmux, and I wasn't sure the Yakmux shared data coming in on one port to a device on another port.  I also wasn't sure joining the leads at the Yak would work (ie. physically connecting the leads at the Yak)

I think that is the whole point of the mux - to multiplex all the signals to all the ports.

Do you see the GGA sentence coming in from the GPS device?

You should be able to add a TCP network connection in OpenCPN:
Protocol: TCP
Address: localhost
DataPort: 10110
check receive only
and then once added you will be able to pull up the NMEA debug window and see what sentences are available

I would use this instead of the SignalK connection you have (then you can use it to debug)

on the outgoing side, if you transmit only RMB, APB, XTE then you wont get loops
Protocol: UDP
Address: localhost
DataPort: 10110
Check Output only
in the Output filtering box "transmit sentences" RMB, APB, XTE

don't ignore any sentences in SignalK (you have RMB and APB ignored)

once you have done this show us the openCPN debug window
Reply
#6
(2021-10-28, 11:28 PM)Techstyle Wrote:
(2021-10-28, 10:43 PM)Island_Moose Wrote:
(2021-10-28, 03:09 AM)Techstyle Wrote: how is the VHF connected to the system? if you connect it to the Yakmux it will get the GPS signals directly from the GPS?

Ive connected the vhf to the Rpi with a RS485 serial usb cable.  I was concerned about sending ALL nmea data to the vhf if I connected it directly to the Yakmux, and I wasn't sure the Yakmux shared data coming in on one port to a device on another port.  I also wasn't sure joining the leads at the Yak would work (ie. physically connecting the leads at the Yak)

I think that is the whole point of the mux - to multiplex all the signals to all the ports.

Do you see the GGA sentence coming in from the GPS device?

You should be able to add a TCP network connection in OpenCPN:
Protocol: TCP
Address: localhost
DataPort: 10110
check receive only
and then once added you will be able to pull up the NMEA debug window and see what sentences are available

I would use this instead of the SignalK connection you have (then you can use it to debug)

on the outgoing side, if you transmit only RMB, APB, XTE then you wont get loops
Protocol: UDP
Address: localhost
DataPort: 10110
Check Output only
in the Output filtering box "transmit sentences" RMB, APB, XTE

don't ignore any sentences in SignalK (you have RMB and APB ignored)

once you have done this show us the openCPN debug window

I'm getting good GPS sentences in OpenCPN, the plotter is working perfectly.   I just can't find a way to send any data out of CPN (I want to send data to my autopilot and VHF).


Attached Files
.txt   rewired.txt (Size: 2.63 KB / Downloads: 18)
Reply
#7
(2021-10-29, 12:09 AM)Island_Moose Wrote:
(2021-10-28, 11:28 PM)Techstyle Wrote:
(2021-10-28, 10:43 PM)Island_Moose Wrote:
(2021-10-28, 03:09 AM)Techstyle Wrote: how is the VHF connected to the system? if you connect it to the Yakmux it will get the GPS signals directly from the GPS?

Ive connected the vhf to the Rpi with a RS485 serial usb cable.  I was concerned about sending ALL nmea data to the vhf if I connected it directly to the Yakmux, and I wasn't sure the Yakmux shared data coming in on one port to a device on another port.  I also wasn't sure joining the leads at the Yak would work (ie. physically connecting the leads at the Yak)

I think that is the whole point of the mux - to multiplex all the signals to all the ports.

Do you see the GGA sentence coming in from the GPS device?

You should be able to add a TCP network connection in OpenCPN:
Protocol: TCP
Address: localhost
DataPort: 10110
check receive only
and then once added you will be able to pull up the NMEA debug window and see what sentences are available

I would use this instead of the SignalK connection you have (then you can use it to debug)

on the outgoing side, if you transmit only RMB, APB, XTE then you wont get loops
Protocol: UDP
Address: localhost
DataPort: 10110
Check Output only
in the Output filtering box "transmit sentences" RMB, APB, XTE

don't ignore any sentences in SignalK (you have RMB and APB ignored)

once you have done this show us the openCPN debug window

I'm getting good GPS sentences in OpenCPN, the plotter is working perfectly.   I just can't find a way to send any data out of CPN (I want to send data to my autopilot and VHF).

there doesn't seem to be any positions in your GGA sentence 

well you were screening out RMB and APB which have Autopilot sentences on them so you may want to not do that.  As for the VHF what do you have selected in the SignalK to NMEA0183 plugin?

read this page:  https://github.com/SignalK/signalk-to-nmea0183
Reply
#8
(2021-10-29, 12:40 AM)Techstyle Wrote:
(2021-10-29, 12:09 AM)Island_Moose Wrote:
(2021-10-28, 11:28 PM)Techstyle Wrote:
(2021-10-28, 10:43 PM)Island_Moose Wrote:
(2021-10-28, 03:09 AM)Techstyle Wrote: how is the VHF connected to the system? if you connect it to the Yakmux it will get the GPS signals directly from the GPS?

Ive connected the vhf to the Rpi with a RS485 serial usb cable.  I was concerned about sending ALL nmea data to the vhf if I connected it directly to the Yakmux, and I wasn't sure the Yakmux shared data coming in on one port to a device on another port.  I also wasn't sure joining the leads at the Yak would work (ie. physically connecting the leads at the Yak)

I think that is the whole point of the mux - to multiplex all the signals to all the ports.

Do you see the GGA sentence coming in from the GPS device?

You should be able to add a TCP network connection in OpenCPN:
Protocol: TCP
Address: localhost
DataPort: 10110
check receive only
and then once added you will be able to pull up the NMEA debug window and see what sentences are available

I would use this instead of the SignalK connection you have (then you can use it to debug)

on the outgoing side, if you transmit only RMB, APB, XTE then you wont get loops
Protocol: UDP
Address: localhost
DataPort: 10110
Check Output only
in the Output filtering box "transmit sentences" RMB, APB, XTE

don't ignore any sentences in SignalK (you have RMB and APB ignored)

once you have done this show us the openCPN debug window

I'm getting good GPS sentences in OpenCPN, the plotter is working perfectly.   I just can't find a way to send any data out of CPN (I want to send data to my autopilot and VHF).

there doesn't seem to be any positions in your GGA sentence 

well you were screening out RMB and APB which have Autopilot sentences on them so you may want to not do that.  As for the VHF what do you have selected in the SignalK to NMEA0183 plugin?

read this page:  https://github.com/SignalK/signalk-to-nmea0183

I selected everything in the SignalK to nmea0183 plugin, and relevant GPS sentences in the nmea0183 to nmea0183 plugin.
Reply
#9
(2021-10-29, 01:00 AM)Island_Moose Wrote:
(2021-10-29, 12:40 AM)Techstyle Wrote:
(2021-10-29, 12:09 AM)Island_Moose Wrote:
(2021-10-28, 11:28 PM)Techstyle Wrote:
(2021-10-28, 10:43 PM)Island_Moose Wrote: Ive connected the vhf to the Rpi with a RS485 serial usb cable.  I was concerned about sending ALL nmea data to the vhf if I connected it directly to the Yakmux, and I wasn't sure the Yakmux shared data coming in on one port to a device on another port.  I also wasn't sure joining the leads at the Yak would work (ie. physically connecting the leads at the Yak)

I think that is the whole point of the mux - to multiplex all the signals to all the ports.

Do you see the GGA sentence coming in from the GPS device?

You should be able to add a TCP network connection in OpenCPN:
Protocol: TCP
Address: localhost
DataPort: 10110
check receive only
and then once added you will be able to pull up the NMEA debug window and see what sentences are available

I would use this instead of the SignalK connection you have (then you can use it to debug)

on the outgoing side, if you transmit only RMB, APB, XTE then you wont get loops
Protocol: UDP
Address: localhost
DataPort: 10110
Check Output only
in the Output filtering box "transmit sentences" RMB, APB, XTE

don't ignore any sentences in SignalK (you have RMB and APB ignored)

once you have done this show us the openCPN debug window

I'm getting good GPS sentences in OpenCPN, the plotter is working perfectly.   I just can't find a way to send any data out of CPN (I want to send data to my autopilot and VHF).

there doesn't seem to be any positions in your GGA sentence 

well you were screening out RMB and APB which have Autopilot sentences on them so you may want to not do that.  As for the VHF what do you have selected in the SignalK to NMEA0183 plugin?

read this page:  https://github.com/SignalK/signalk-to-nmea0183

I selected everything in the SignalK to nmea0183 plugin, and relevant GPS sentences in the nmea0183 to nmea0183 plugin.
Did you check settings.json for: 
Code:
"toStdout": "nmea0183out"
Reply
#10
(2021-10-29, 01:11 AM)Techstyle Wrote:
(2021-10-29, 01:00 AM)Island_Moose Wrote:
(2021-10-29, 12:40 AM)Techstyle Wrote:
(2021-10-29, 12:09 AM)Island_Moose Wrote:
(2021-10-28, 11:28 PM)Techstyle Wrote: I think that is the whole point of the mux - to multiplex all the signals to all the ports.

Do you see the GGA sentence coming in from the GPS device?

You should be able to add a TCP network connection in OpenCPN:
Protocol: TCP
Address: localhost
DataPort: 10110
check receive only
and then once added you will be able to pull up the NMEA debug window and see what sentences are available

I would use this instead of the SignalK connection you have (then you can use it to debug)

on the outgoing side, if you transmit only RMB, APB, XTE then you wont get loops
Protocol: UDP
Address: localhost
DataPort: 10110
Check Output only
in the Output filtering box "transmit sentences" RMB, APB, XTE

don't ignore any sentences in SignalK (you have RMB and APB ignored)

once you have done this show us the openCPN debug window

I'm getting good GPS sentences in OpenCPN, the plotter is working perfectly.   I just can't find a way to send any data out of CPN (I want to send data to my autopilot and VHF).

there doesn't seem to be any positions in your GGA sentence 

well you were screening out RMB and APB which have Autopilot sentences on them so you may want to not do that.  As for the VHF what do you have selected in the SignalK to NMEA0183 plugin?

read this page:  https://github.com/SignalK/signalk-to-nmea0183

I selected everything in the SignalK to nmea0183 plugin, and relevant GPS sentences in the nmea0183 to nmea0183 plugin.
Did you check settings.json for: 
Code:
"toStdout": "nmea0183out"
No, how do I do that?
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)