This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
OpenCPN and Signal-K
#1
Just had an issue with the latest version of OpenCPN 5.6.0.

When I would open OpenCPN it would work for a few seconds and then slow down so much it effectively froze. 

After a little messing around it appears that OpenCPN does not handle the Signal K data from OP. With just the GPS SignalK data only it overwhelmed OpenCPN.

I went in and disabled SignalK in OpenCPN and added the gps by NMEA0183 and all was well.

This happened on two different devices with different hardware.
Reply
#2
It works very well with the data from the SignalK server. But with OpenCPN there is automatic server search setting switched on. Right under.

Switch this to off and set port adress to locahost and port to 3000. To set the serial device, the best way is to use the Serial applicatien, give serial an "alias" then to connections and transfer the serial to signalk. Wait for the SK server to start.

Bram
Reply
#3
Thanks for pointing me in the right direction Bram! Worked great!
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)