This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
random crashes with assert failure
#1
since updating my pi 3+ to the latest openPlotter and OCN 5.2.4.and now 5.6.0 the OCN has been throwing errors about an assert failure. This happens every time I first start up and then also at random times while sailing usually while I am trying to interact with the chart or perhaps a route. Sometimes I am able to press the continue button.Other times it shuts down and I have to start it all up again. This is a big problem if I am in the middle of some tricky navigation.
I have attached the backtraces on the last 3, plus the most recent log and screenshot.
I don't know how to reproduce this except perhaps on first load when I move the mouse.
Someone on OpenCPN suggested it might have to do with old wxWidget libraries? Don't know how to fix that.
Any help would be much appreciated


Attached Files Image(s)
   

.txt   backtrace.txt (Size: 772 bytes / Downloads: 4)
.txt   backtrace2.txt (Size: 378 bytes / Downloads: 4)
.txt   backtrace3.txt (Size: 555 bytes / Downloads: 4)
.txt   opencpn.log.save3.txt (Size: 25.28 KB / Downloads: 5)
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)