This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Pican-M not working after upgrade.

Upgraded raspberry pi 4 and opencpn 5.6 and seems like the picanm nmea0183 is no longer outputting nmea data on /dev/ttyS0 or /dev/ttyAMA0. Meaning now my vhf which was previously getting the GPS details is no longer getting themSad

I have gone through all the setup details could find but still not working. 

I have also tried to configure the serial port manually from /boot/config.txt like below with no luck.

#UART0 aka ttyAMA0 pin 14,15

If anyone has some troubleshooting ideas please let me know.

Did you ever figure this out? I'm having the same issue. The serial port works fine with Openplotter 2, but a fresh install of Openplotter 3 results in a non-working /dev/ttyS0.

Forum Jump:

Users browsing this thread: 1 Guest(s)