This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
OpenCPN and signal K freezes
#1
Hi,

I've a problem with signal K data in OpenCPN. I've the following setup:

AIS: Quark-Elec A033 Bi-Dir with WiFi Multiplexer and SeaTalk
Multiplexer: Em-trak b953
Plotter: Raspberry pi 4 + openplotter 3 image.

I also have a Nasa Clipper Wind device but also without this device connected a get the problems.

As soon as I connect data from the multiplexer via usb to my raspberry OpenCPN freezes after half a minute. I connect the data to OpenCPN via signal K. In signal K I don't see any error and I see a nice regular update of the data.

Has anyone experienced something similar or any idea what could cause this behavior.

Kind Regards,

Anna
Reply
#2
I've had crashes with both NMEA0183 and signalk connections to signalk enabled at the same time. Do you need signalk data in opencpn? NMEA0183 covers most data opencpn can use.
Reply
#3
(2022-04-19, 08:52 AM)PaddyB Wrote: I've had  crashes with both NMEA0183 and signalk connections to signalk enabled at the same time. Do you need signalk data in opencpn? NMEA0183 covers most data opencpn can use.

Thank you so much for the quick reply!

I've only 1 connection in opencpn at the moment, this is my signalk connection, but I could try to use the serial data connection in opencpn. I have signal k because I like the dashboard from signal k as well.

Do I understand correctly that adding a serial connection as described here: https://opencpn.org/wiki/dokuwiki/doku.p...onnections maybe solves my problem?

Anna
Reply
#4
could you open opencpn typing "opencpn" in a terminal to see if any error is raised in the terminal when freezing?
Reply
#5
(2022-04-19, 07:58 PM)Sailoog Wrote: could you open opencpn typing "opencpn" in a terminal to see if any error is raised in the terminal when freezing?

Thanks for the reply! I'll try it this weekend when I'm at my boat again Smile
Reply
#6
on openplotter I connected the signals of the boat's instrumentation (gps, depth, water temperature, speed, wind direction, etc. etc.).  all signals are managed by signalk and are active. while opencpn reads them regularly, Avnav does not receive them from signalk.  so yes Avnav all displays are cleared and the gps signal is absent.  Can anyone tell me where the problem lies?  a thousand thanks
Reply
#7
Please check that your datetime is correct. Avnav checks data timesstamp!
https://www.wellenvogel.net/software/avn...ml?lang=en search for ignoreTimestamp
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)