This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Node JS versions
#1
I need to update Node JS on my Raspberry Pi with the OpenPlotter setup. And before that does anyone know if I Open Plotter works good with a newer version of Node JS? If so what’s the best newest version to use?
Reply
#2
when you install openplotter-signalk-installer the correct nodejs version is installed you do not need to do anything else.

openplotter 2 uses nodejs 10 and openplotter 3 uses nodejs 16, if you use anything else we can not confirm signal k server will work as expected.
Reply
#3
I need verion 16, but have version 10, this means I don’t have OpenPlotter 3. Is it possible to update from OpenPlotter 2 to 3 or do I need to do a fresh install?
Reply
#4
You need a fresh install, next week we will go to stable for OpenPlotter Starting and OpenPlotter Headless:

https://forum.openmarine.net/showthread.php?tid=3878
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)