This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Running PI as AP but cannot use http://openplotter.local from mobile
#1
I am running OpenCPN 5.6.2,  openplotter v3 2022, Linux openplotter 5.15.32-v7l,  on a Raspberry pi 4 model B

There are no warnings when running the "Check system" on OpenPlotter
I am using my PI as an AT setting the Network up as shown in the documentation "AP (on board)"
Then I am connecting to the SSID openplotter on my mobile. I can connect to SignalK using http://openplotter.local:3000 on my mobile. I CANNOT connect to http://openplotter.local
Then I get connection refused.
What am I missing?
Reply
#2
your mobile must be connectid to your LOCAL wifi to. connnect to any local domain. maybe it is possible to connect via the 10.xxx or 192.168.xxx directy ip adresses - but not via your mobilenet as these are not routed for securty reasons.

holger
Reply
#3
(2022-08-09, 08:55 PM)holgerw Wrote: your mobile must be connectid to your LOCAL wifi to. connnect to any local domain. maybe it is possible to connect via the 10.xxx or 192.168.xxx directy ip adresses - but not via your mobilenet as these are not routed for securty reasons.

holger

My mobile is connected to a LAN created by using PI as an AP (Acess Point). I am not using the mobile net. I can also  to the PI from the mobile and ping the mobile from PI. This shows that the LAN works.

I thought I could access OpenPlotter from using http://openplotter.local from my mobile. I can also use the IP address directly, but I get always get ERR_CONNECTION_REFUSED.
Have I misunderstood something?
Jarle
Reply
#4
use http://openplotter.local:3000 for signalk-server.

default there is no http server running on openplotter so you have to use an portnumber.
Reply
#5
(2022-08-10, 04:50 PM)holgerw Wrote: use http://openplotter.local:3000 for signalk-server.

default there is no http server running on openplotter so you have to use an portnumber.

http://openplotter.local:3000 for signalK server works, but how can i share openpcn to my mobile. Is there a portnumer to use in http://openplotter.local:????
Jarle
Reply
#6
you can use an VNC App on your mobile to get the screen.
also there is an OpenCPN App for Android.

openplotter-network shows you all the used ip and portnumbers.
Reply
#7
(2022-08-10, 05:03 PM)holgerw Wrote: you can use an VNC App on your mobile to get the screen.
also there is an OpenCPN App for Android.

openplotter-network shows you all the used ip and portnumbers.

Thanks for you answer. That clarified a lot.
I think the OpenPlotter documentation is not explaining clearly how to access the OpenPlotter on Pi from the cockpit through  mobile devices.

I notice that when installing the headless software both SSH and Remote Desktop are enabled.
One last question: Is there perhaps better to use the Headless installation if one wants to access the Pi from mobile?


Jarle
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)