This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Problem with i2c: enabled | not running
#1
I don't know if it's a bug...
I use Openplotter 2.9.1 on raspberry Pi 4 model B. the system is installed on USB SSD everything works regularly on an RPI purchased in 2019 Two months ago I bought another 2 raspberry Pi 4 model B but on these (on both) i2c does not work, I tried with more devices but the problem is the same. At startup, the check reports: i2c enabled | not running
In the log I find this:
Code:
Aug 30 22:13:20 Berry1 openplotter-i2c-read[435]: Traceback (most recent call last):
Aug 30 22:13:20 Berry1 openplotter-i2c-read[435]:   File "/usr/bin/openplotter-i2c-read", line 11, in <module>
Aug 30 22:13:20 Berry1 openplotter-i2c-read[435]:     load_entry_point('openplotterI2c==2.2.1', 'console_scripts', 'openplotter-i2c-read')()
Aug 30 22:13:20 Berry1 openplotter-i2c-read[435]:   File "/usr/lib/python3/dist-packages/pkg_resources/__init__.py", line 489, in load_entry_point
Aug 30 22:13:20 Berry1 openplotter-i2c-read[435]:     return get_distribution(dist).load_entry_point(group, name)
Aug 30 22:13:20 Berry1 openplotter-i2c-read[435]:   File "/usr/lib/python3/dist-packages/pkg_resources/__init__.py", line 2793, in load_entry_point
Aug 30 22:13:20 Berry1 openplotter-i2c-read[435]:     return ep.load()
Aug 30 22:13:20 Berry1 openplotter-i2c-read[435]:   File "/usr/lib/python3/dist-packages/pkg_resources/__init__.py", line 2411, in load
Aug 30 22:13:20 Berry1 openplotter-i2c-read[435]:     return self.resolve()
Aug 30 22:13:20 Berry1 openplotter-i2c-read[435]:   File "/usr/lib/python3/dist-packages/pkg_resources/__init__.py", line 2417, in resolve
Aug 30 22:13:20 Berry1 openplotter-i2c-read[435]:     module = __import__(self.module_name, fromlist=['__name__'], level=0)
Aug 30 22:13:20 Berry1 openplotter-i2c-read[435]:   File "/usr/lib/python3/dist-packages/openplotterI2c/openplotterI2cRead.py", line 18, in <module>
Aug 30 22:13:20 Berry1 openplotter-i2c-read[435]:     import socket, time, threading, board, busio
Aug 30 22:13:20 Berry1 openplotter-i2c-read[435]: ModuleNotFoundError: No module named 'board'
Aug 30 22:13:20 Berry1 systemd[1]: openplotter-i2c-read.service: Main process exited, code=exited, status=1/FAILURE
Aug 30 22:13:20 Berry1 systemd[1]: openplotter-i2c-read.service: Failed with result 'exit-code'.
The addresses of i2c devices are seen regularly. If I put the same disk in the previous Rpi everything works fine! I don't understand if both new rpi can be faulty or there is a software problem.
Thanks to those who can give me directions.
Reply
#2
somehow the module "board" is missing. Open a terminal and install it typing:

sudo python3 -m pip install --upgrade --force-reinstall adafruit-blinka
Reply
#3
I've tried everything I can find on the forum trying to get I2c running and data to instrument panel on a Pi 4b plus pican m hat.
Tried the suggested solution on this one and now have I2c sensor running on the system check. But still no data. so something else must be missing from the installation.
Reply
#4
Any error in terminal?
Reply
#5
Guten Abend,

haben Sie das Problem lösen können?
Ich stehe jetzt vor der gleichen Aufgabe das mein I2C: enabled not Running
Reply
#6
Guten Abend,

wie wurde das Problem behoben?
Ich stehe jetzt vor der gleichen Aufgaben.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)