This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Thread Rating:
  • 1 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
openplotter-pypilot 3.x.x beta released
#21
I just cloned https://github.com/pypilot/openplotter-pypilot onto a brand new openplotter 3 image and installed it with sudo python3 setup.py install, and it ran without any major surprises - as systemd services, and the hat service starting without hat hardware. Service can also be started manually, and I could also run pypilot at the prompt for debugging purposes. So it had everything I expected!

Only things were that
- Bottom bar check mentioned that 'hardware serial needed to be enabled', even though I had enabled it in raspi-config and rebooted afterwards. This needed to be done in openplotter-serial (UART0), but the message was not clear.
- There were 3 access request in signalk, but only 1 worked ('ip': '::ffff:192.168.178.96'). Note that I have eth0 connected and tcp6 present in my home network.
- There was a recurring error in the on-screen build log that looked ugly (see below). I don't like errors that I should ignore. False negatives lead to ignoring true negatives.
- I could not scroll back in the on-screen build log nor copy text from it.

But the bottom line is that from my point I can definitely see convergence. Keep up the good work!

[Image: 191850350-ce8ca22d-157e-4142-a1b1-05f492806dcc.png]

[Image: 191849990-b891f055-8172-4059-a19f-31d1e6953f83.png]
Reply
#22
I have seen the TCSAFLUSH... not sure exactly what causes it, but it is a warning not an error.

the build log needs to prevent user input or moving the cursor...
Reply
#23
These issues you found were expected but your test give me more clues, thanks ironman. Hopefully I can clean it this weekend.

I may be wrong but through raspi-config I think you enable/disable UART1 (a virtual interface), not UART0. I do not have a Raspi right now to test.

After switching back to systemd, pypilot now starts before the global token management and pypilot makes its own requests. It can be fixed.
Reply
#24
I'm not sure why pypilot should not make its own requests?

It is preferable that pypilot start quickly... sometimes the autopilot is needed.
Reply
#25
Because the openplotter way is more eficient, it is integrated with other apps and guides the user to get the connection at each step. Do not worry pypilot will start just as fast as now. No delays believe me.
Reply
#26
Sorry, I meant the startup speed being related to using systemd.

Let me know if any changes need to be made in pypilot to regarding tokens. Which other applications use signalk tokens that the "global token management" handles? I can disable token management in pypilot with a command line switch if needed.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)