This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Motor Controller Not Found
(2022-12-22, 04:00 PM)seandepagnier Wrote: if you see "bind_failed"   it means another instance of pypilot is running.

First verify the serial port:
ls -l /dev/serial0

it should point to /dev/ttyAMA0

Next stop pypilot:
sudo service pypilot stop

Now try running on the console pypilot_servo, and check the results.    You may need to add /dev/ttyAMA0 to the list of serial ports pypilot can use.

Sean, you write: "You may need to add /dev/ttyAMA0 to the list of serial ports pypilot can use". How does one do it?
(2022-12-25, 10:09 PM)seandepagnier Wrote: Hi

Sorry this is because...   I use spaces and sailoog uses tabs and I made a mistake merging some scripts.

I corrected in git, if you can pull from:

Just issue
sudo python3 install

Also consider using a tinypilot image for a pi 3b at least as backup on another sd card since it would avoid configuration and pitfalls.

I will try to make a video setting up openplotter

Hi Sean 

Well I'm back trying again.  But still not much luck 
1/ tried installing a 2.x Openplotter/Pypilot Image, and only have the motor controller and IMU connected, it sees the IMU but never the motor controller.    The Pypilot Servo util was reporting a timeout on dev/ttyAMA0 and no other errors.   

2/As a Last resort I've tried to install  a Tinypilot img (16/11/2021 version ) onto an SD card. 
but am not certain searching on the forum if is a RPI 3B+ is fully supported.? 
When I boot with the latest tinypilot img, there is no SSID broadcast from the RPI, so cant connect to it via VNC?   I think that is one of the issues with trying to run Tiny pilot on a 3b+? 
I've tried to use Putty to connect to either  or a via aweb browser. The RPI has an ethernet cable plugged in, so I could perhaps get to its address that way. 

Am I wasting my time trying to make this work on an RPI 3b+
Did you try the tinycore 13 image:

I am working on software now for new images.

It may even be that it is just wired backwards (rx and rx). Do you have 12 volts powering the motor controller?
(2023-01-04, 02:36 PM)seandepagnier Wrote: Did you try the tinycore 13 image:

I am working on software now for new images.  

It may even be that it is just wired backwards (rx and rx).    Do you have 12 volts powering the motor controller?

Hi Sean 

Thanks for the link I previously grabbed the most recent Tinypilot image. 

The one in your link is better, and I can now get access to the Wifi, and view the browser interface.

The web interface still says no motor controller.   But it can see the MPU 9250

I have a 12v Power supply hooked up, and GPIO pins wired.  Previously when trying to make this all work Ive tried swapping the RX/tx pins around, but it reported the same error. 
I've never seen any lights other than the Red LED for pwr light up on the Motor controller.  Should they be lit if the board has pwr/comms. 

My last thought is perhaps for some reason the GPIO pins on my RPI are NBG.  I could load another SD card with just a plain RPI OS on it, and see if there are any basic comms utils I can test it with. 

Any suggestion on what utils I might use to fault find with. 

Have done a fair few projects with Arduino's and not had many issues. But RPI's seem a lot more fiddly to make work.
Have just edited this, as I unplugged everything.  
Right  at the start of this blog I mentioned which wires were connected to which pins on the  GPIO.  But got my magnifying glasses out and looked at the pin desingations on the PCB,  then tested what colours those were on the end of the supplied plug .   It turns out when continuity testing that the black wire is Vcc 3.3V, so it was wired completely incorrectly. 

Tracing this thru I re-wired the UART GPIO as follows:    

Most likely the colours have been different on different board versions, and I also had the red core previously connected to VCC 3.3v.  
re-wired the GPIO in accordance with the above.  After looking closely at the priniting on the PCB.   
RX and TX lights have all blinked, and there are no errors listed in Tiny Pilot.  

Woo Hoo!! Awesome. 

Now onto calibration, testing the drive (which worked fine) and figuring out some sort of remote control for the Tiny Pilot, in case the boats Tablet/Web browser runs out of pwr etc. 

wondering about some sort of simple LCD screen for the Tiny Pilot on an RPI 3b+ , and if any is supported.  

Anyhow thanks for being patient Sean, I got there in the end !!
really sorry about the wire colors. It is somewhat confusing now but I ordered a lot of these and get different wiring patterns.

At least no damage should be caused by wiring them wrong.

I tried to list the colors here:

Not sure what you mean for screen. Typically lcd jlx12964 is used by pypilot using spi, but otherwise you could use hdmi.
I've just joined the forum and can't see a button to start a new thread for this so please correct me if I'm missing something.

I have a working pypilot with the small motor controller and I want to use a Devantech MD03 that I already have to drive a larger motor.

I have bought an Arduino clone as suggested and installed motor.ino and crc.h on it and connected the serial output of the pypilot to it through a level converter but I am not seeing the tx or rx led flashing.

Am I missing something, I read about settings on cheap nano's being incorrect but that is beyond my experience.

As I say the serial data works perfectly on the existing motor controller.
Indeed I also have the experience that some nano's don't seem to have their serial lights flashing. Don't know if that's a setting or hardware failure, but it never seemed to have any consequences.
Well it's beaten me, I tried opto couplers but then read that they might not be fast enough for the data, I also read that I could connect Rx direct to the Nano and wire the Tx through a voltage divider but that didn't work either.
I think I'll just wait for the store to come back online and buy a high current motor controller!
the data baud rate is only 38400 so most opto should be ok.

Difficult to say what the issue is if it is hardware or software.
Well it's working fine with the original motor controller which makes me think it's the Arduino.....only thing is I've never seen any characters on the Arduino IDE serial monitor-is that normal? unless I load a 'hello' sketch into it, that works ok.

Do you have any idea when you expect to have the store online again?

Forum Jump:

Users browsing this thread: 1 Guest(s)