This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[CLOSED] OP3 64-bits: Errors running SignalK updates
Updating SignalK fails on OP3, 64-bits. Sample output:

npm verb stack Error: ENOTEMPTY: directory not empty, rename '/usr/lib/node_modules/signalk-server' -> '/usr/lib/node_modules/.signalk-server-1toVL4zJ'
npm verb cwd /home/pi
npm verb Linux 5.15.32-v8+
npm verb node v16.16.0
npm verb npm  v9.2.0
npm ERR! syscall rename
npm ERR! path /usr/lib/node_modules/signalk-server
npm ERR! dest /usr/lib/node_modules/.signalk-server-1toVL4zJ
npm ERR! errno -39
npm ERR! ENOTEMPTY: directory not empty, rename '/usr/lib/node_modules/signalk-server' -> '/usr/lib/node_modules/.signalk-server-1toVL4zJ'
npm verb exit -39
npm verb unfinished npm timer reify 1672911334630
npm verb unfinished npm timer reify:retireShallow 1672911367098
npm verb code -39
npm ERR! A complete log of this run can be found in:
npm ERR!     /root/.npm/_logs/2023-01-05T09_35_34_488Z-debug-0.log

This happens when you try to "reinstall SignalK". Running "sudo npm install -g signalk-server" also fails with a similar error.

This doesn't happen when using a 32-bits image.
I'm also having the same issue.
For me this started on a fresh install and when i ran the SignalK update from the SK/server webpage. That failed.

I've since tried to reinstall SK from the SK installer, which failed.
I've reinstalled using a new SD card and this problem is no longer happening for me.
Reinstalling signalk fixed this problem.

Same here: fresh install on 64-bit version goes well until update to signalk 2.2.0 Reinstall gives the same issue. Complete fresh install on different sd card works; after update to 2.2.0 still the same issues
Updated NPM manually and did a clean install as written in

That did the trick.

(Had to move the old dir to another location)
Same issue on my OP4 installation. Deleted folder .signalk-server-1toVL4zJ and it worked fine after reinstallation.

Forum Jump:

Users browsing this thread: 1 Guest(s)