This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
OP3 windtrim Navman/raymarine
#1
Photo 
Hi all, 
I migrated recently to op3 and my windtrim config doesn't work anymore...
here my old solution..

I need to send, to the raymarine st1000+, VWR nmea0183 sentences generated by signalk to nmea0183 plugin..

this is my new signalk setup:

   

   

   

   

   

I tried two "pilot's usb/serial adapter"

and the following connections

raymarine
st1000+                     usb/serial adapter

nmea+ --------------------> A 
nmea-  --------------------> B

nmea+ --------------------> A
GRD     --------------------> B
 [Image: attachment.php?aid=259]

... but the pilot doesn't want to switch to windtrim mode (auto+stanby)

some tips?

i'm missing something .... but what?

rpi3
OP3
hub usb
gps usb

check sistem log:

Checking NTP server... | running
Checking Power off management... | disabled
Checking Shutdown management... | disabled
Checking OpenPlotter autostart... | enabled
Checking rescue mode... | disabled
Checking debugging mode... | disabled
Checking system log file size... | System log file size: 21.83 MB
Checking OpenPlotter packages source... | added
Checking SDR processes... | SDR AIS is not running
Checking Notifications... | running | Access to Signal K server validated
Checking GPIO... | pigpiod running | Seatalk1 disabled | 1W enabled | pulses disabled | digital disabled | openplotter-gpio-read not running | Access to Signal K server validated
Checking I2C sensors... | openplotter-i2c-read running | I2C enabled | Access to Signal K server validated
Checking pypilot... | pypilot_boatimu running | openplotter-pypilot-read running | Access to Signal K server validated | pypilot_web not running | pypilot_hat not running
Checking WIFI Access Point password... | changed
Checking serial connections alias... | All your serial connections have an assigned alias
Checking Dashboards... | Kip enabled
Checking OpenCPN... | running |  | autostart disabled
Checking Signal K server... | running
Checking serial connections conflicts... | no conflicts
Checking network connections conflicts... | no conflicts
Checking GPIO conflicts... | no conflicts
CHECK SYSTEM FINISHED
Reply
#2
I assume you want to use the /dev/ttyOP_pilotout device to send data. You need to add the event nmea0183out in the field "Output events" of your signal k connection for this device.

when you set a serial connection in signal k, it works only as input by default, if you want it to work as output too, you need to tell the Signal k server what events you want to send. Events are like "labels", you can label any data entry (event) and then use that label to identify the data and define outputs. Events explained: https://openplotter.readthedocs.io/en/3....exing.html
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)