This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Edit openplotter.conf file and remove the value of variable sensors:
sensors =
Thank ! That has solved the start issue of OpenPlotter. Still the same mystery about RTIMULib
We can't change the files imu/ and openplotter as you did in your github fork at the moment. Otherwise other users could get errors when selecting 9255 with the old rtimulib.
So redo these changes to 0.11.9.
When you then select 9255 the errors shouldn't come again.
It works!!!  Smile
So I can definitely say that there are remains of an RTIMU lib in the system.
You need to remove all the RTIMUlib files in usr/lib/... but ALSO all the python files hidden everywhere (usr/lib/python2.7, usr/lib/python3.4, usr/lib/python3 , also in usr/local/lib/python/...).
After what I reinstalled RTIMU (and I added python3 install).

Now when I open openplotter, the good file is created, also with the creating "detected-....ini". The value of the magnetic heading and the pitch are now visible and working in SignalK. (But they (+temperature + pression + humidity) are not send to NMEA183 at the moment, only GPS data Angry  )

@sailoog : I would be you, I would maybe generate a new NOOB without the corrupted old files. That is maybe why you say that RTIMULib is not stable. And it would speed up the process of reinstalling the system after some experimentation. Angel

corrupted old files? they are not corrupted, they work right for the repo they belong. I think the original RTIMULib is stable. We need to test other forks that add support for more IMUs but we need to check this very well.

I prefer to keep the self-update system until the stable version and not force users to burn another SD. I am sure we can start testing another RTIMUlib fork and delete old files on every major update before compiling the new fork.

Could you make a list of files to delete? we could trace the code to search for exactly all files but you have already done some work.

Here you have what I just did with a clean installation (And I persist, a noob version of the Beta would save one or two hours of update Smile ). I cannot promise I haven't forgotten a files or broken some functions.

Is that normal that you have files named with 7.2.1 and others with 8.0.0? That's why I am talking about old files.

sudo rm /usr/lib/
sudo rm /usr/lib/
sudo rm /usr/lib/
sudo rm /usr/lib/python3/dist-packages/
sudo rm /usr/lib/python3/dist-packages/RTIMULib-7.2.1.egg-info
sudo rm /usr/lib/python2.7/dist-packages/
sudo rm /usr/lib/python2.7/dist-packages/RTIMULib-7.2.1.egg-info
sudo rm /usr/lib/
sudo rm /usr/lib/
sudo rm /usr/lib/
sudo rm /usr/bin/RTIMULibCal
sudo rm /usr/bin/RTIMULibDrive11
sudo rm -r /usr/include/IMUDrivers
sudo rm /usr/include/RTFusion.h
sudo rm /usr/include/RTFusionKalman4.h
sudo rm /usr/include/RTFusionRTQF.h
sudo rm /usr/include/RTIMUAccelCal.h
sudo rm /usr/include/RTIMUCalDefs.h
sudo rm /usr/include/RTIMUHal.h
sudo rm /usr/include/RTIMULib.h
sudo rm /usr/include/RTIMULibDefs.h
sudo rm /usr/include/RTIMUMagCal.h
sudo rm /usr/include/RTIMUSettings.h
sudo rm /usr/include/RTMath.h
sudo rm /usr/local/bin/RTIMULibCal
sudo rm /usr/local/bin/RTIMULibDemo
sudo rm /usr/local/bin/RTIMULibDemoGL
sudo rm /usr/local/bin/RTIMULibDrive
sudo rm /usr/local/bin/RTIMULibDrive10
sudo rm /usr/local/bin/RTIMULibDrive11
sudo rm -r /usr/local/include/IMUDrivers
sudo rm /usr/local/include/RTFusion.h
sudo rm /usr/local/include/RTFusionKalman4.h
sudo rm /usr/local/include/RTFusionRTQF.h
sudo rm /usr/local/include/RTIMUAccelCal.h
sudo rm /usr/local/include/RTIMUCalDefs.h
sudo rm /usr/local/include/RTIMUHal.h
sudo rm /usr/local/include/RTIMULib.h
sudo rm /usr/local/include/RTIMULibDefs.h
sudo rm /usr/local/include/RTIMUMagCal.h
sudo rm /usr/local/include/RTIMUSettings.h
sudo rm /usr/local/include/RTMath.h
sudo rm /usr/local/lib/
sudo rm /usr/local/lib/
sudo rm /usr/local/lib/
sudo rm /usr/local/lib/
sudo rm /usr/local/lib/
sudo rm /usr/local/lib/
sudo rm /usr/local/lib/python2.7/dist-packages/
sudo rm /usr/local/lib/python2.7/dist-packages/RTIMULib-8.0.0.egg-info

cd ~/.config
mkdir compiling
cd compiling

cd ~/.config/compiling
git clone
cd RTIMULib2/Linux
mkdir build
cd build
cmake ..
make -j4 -s
sudo make -s install
sudo ldconfig
cd ..
cd RTIMULibCal
make -j4 -s
sudo make -s install
cd ..
cd RTIMULibDrive
make -j4 -s
sudo make -s install
cd ..
cd RTIMULibDrive10
make -j4 -s
sudo make -s install
cd ..
cd RTIMULibDemo
make -j4 -s
sudo make -s install
cd ..
make -j4 -s
sudo make -s install
cd ..
cd python
python -q build
sudo python -q install
python3 -q build
sudo python3 -q install

cd ~/.config
sudo rm -rf ~/.config/compiling/
Thanks a lot

There is something weird here...
When you do "sudo make -s install" all target files will be replaced only if there are changes on it (file modification date) and there is not option to force overwriting. This should work, but Python installation only will replace files if the package version is upper. Look at this:
this is the version of the original code:
and this is the version of the forked code:
both are 8.0.0 so when you do "python -q install" nothing is installed but you do not realize because you are installing in silent mode " -q". My theory is that if you edit the version on the forked code to 8.1.0, it will work. You can also force updating doing "python install --force".

I have no time to try this now but if you still have energies to test this, report please.

Do not use silent modes, type:
"sudo make install"
"sudo python install"
instead of:
"sudo make -s install"
"sudo python -q install"
to see what is going on.
I won't do a complete reinstallation for now. It is way to long to do the initial update (more than 2 hours).

However I deleted all the RTIMU files. For all the files not included in "usr/local" I had an error : "file does not exist". Which prove that the 7.2.1 is old and deprecated files.

Then I installed RTIMU from your git (the one in your "update" script. Logically, the .ini files were without MPU9255. Then I just intalled the git from Nick (no cleaning of any file and not updating the version number). and the MPU9255 was back and working.

I am not a programmer and I don't understand everything. But according to me, the python script is updating even if the version number is the same. And the files not in usr/local should be manually deleted in your next update to "clean" the system.

edit: I have updated my repo with all the changes that should fix and add MPU9255, for when you decide to switch to new version of RTIMULib.
I think I got it. An old version of RTIMULIb is installed on Raspbian by default. Actually the Sensor Hat uses this library. If you want to delete old files you should type:

sudo apt-get remove --purge librtimulib-dev librtimulib-utils librtimulib7 python-rtimulib python3-rtimulib

Then I think the last test should be:
Burn a fresh OP and update to latest version.
run: sudo apt-get remove --purge librtimulib-dev librtimulib-utils librtimulib7 python-rtimulib python3-rtimulib
install RTIMULib from Nick repo

If this works we do not need to start a new image, just remove old packages on update sequence, choose a RTIMULib fork from Nick or others and add your code.
Your solution works and it is most probably the cleanest one. Smile

Forum Jump:

Users browsing this thread: 1 Guest(s)