This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Setup Pypilot motor controller with MacArthur HAT
Ops sorry, you are doing nothing wrong. The code of openplotter-pypilot app assumes that if you enable autopilot mode, /dev/ttyAMA0 (UART0) will be always used. This checking was added because if no serial devices are assigned to pypilot, it will start fighting for all the serial devices even the already configured in other applications. But now with the MacArthur HAT you are forced to use another UART if you are already using UART0 for MAIANA or dAISY.

I will publish a new version of openplotter-pypilot fixing this ASAP (maybe tomorrow). In the meantime you can try adding the device from openplotter-serial app and enable autopilot mode in openplotter-pylot app. If I am not wrong pypilot should start.

Messages In This Thread
RE: Setup Pypilot motor controller with MacArthur HAT - by Sailoog - 2023-05-17, 05:05 PM

Forum Jump:

Users browsing this thread: 2 Guest(s)