This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Setup Pypilot motor controller with MacArthur HAT
So today I received my pypilot motor controller and tried to set it up using this tutorial:

Connected the controller to 12V supply, ok

But when I tried to connect to the Rpi UART0, i see that it's already used by MAIANA. Acording to MacArthur HAT docs, UART3 and UART5 are also used (or can be used) by NMEA0183 connections.

So I tried to enable UART4 which aparently use GPIO 8 (CE0_N) and 9 (MISO). By doing so, i see that a new device appears as "ttyAMA1", but when I change the Pypilot app to "Enable autopilot" instead of "IMU only", i get the warning  saying "The device /dev/ttyAMA0 in UART0 should be added to the list of serial ports pypilot manages":


But even if I add an alias to ttyAMA1, and go to Pypilot Serial settings and add that device, the same message stays there


I have no idea what i'm doing wrong or how can I start to diagnose, any help will be much appreciated
Ops sorry, you are doing nothing wrong. The code of openplotter-pypilot app assumes that if you enable autopilot mode, /dev/ttyAMA0 (UART0) will be always used. This checking was added because if no serial devices are assigned to pypilot, it will start fighting for all the serial devices even the already configured in other applications. But now with the MacArthur HAT you are forced to use another UART if you are already using UART0 for MAIANA or dAISY.

I will publish a new version of openplotter-pypilot fixing this ASAP (maybe tomorrow). In the meantime you can try adding the device from openplotter-serial app and enable autopilot mode in openplotter-pylot app. If I am not wrong pypilot should start.
Actually you're right. Even if I get the warning everytime I start pypilot app, it DOES work fine. I'm testing it at home, but the motor controller engages and can move the motor.

So aside for the annoying warning, there's no major issue (and no rush at all IMO).
OK, thanks for reporting.

just in case, if you use UART4 you are disabling the NMEA 2000 feature in the MacArthur HAT. If I am not wrong you can also use UART3 or UART5 and NMEA 0183 1 or NMEA 0183 2 features will be disabled respectively.
Already fixed in openplotter-pypilot 3.2.13
Just checked. Perfect, thanks!

Forum Jump:

Users browsing this thread: 1 Guest(s)