This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
ver 3.x I2C connections.
#11
Thanks very much. The sensors are bme280.
Have a suspicion that I put in never the first time i tried it, before I received your answers. tried setting up the I2c sensors when I installed openplotter on the PI at home about 3 weeks ago. Finding I'm using more and more lower case when two fingered typing. Never worked with linux until I got the Pi, so its a steep learning curve.

that's a good tip on the browsers, I've found Chromium painfully slow.
Reply
#12
(2023-06-16, 01:38 PM)amckeown Wrote: Thanks very much. The sensors are bme280.
Have a suspicion that I put in never the first time i tried it, before I received your answers. tried setting up the I2c sensors when I installed openplotter on the PI at home about 3 weeks ago. Finding I'm using more and more lower case when two fingered typing. Never worked with linux until I got the Pi, so its a steep learning curve.

that's a good tip on the browsers, I've found Chromium painfully slow.

Code:
sudo apt update && sudo apt install firefox-esr

Then save this url as a bookmark

Code:
http://localhost:3000/admin/#/dashboard


Good luck

Alan

In post #7 you say " I ran the i2cdetect command, and it returned the chip on 0x76. Checked and both chips are bme280."

That's inconsistent with what is normal, BME280s are generally 0x77. It would suggest you have BMP280s although a check of the little silver can will confirm. Your assumption may well be correct but if you pick the wrong type when setting it up it will fail so best to be doubly sure.

I have both in one of my systems:


Attached Files Image(s)
   
Reply
#13
(2023-06-16, 01:38 PM)amckeown Wrote: Thanks very much. The sensors are bme280.
Have a suspicion that I put in never the first time i tried it, before I received your answers. tried setting up the I2c sensors when I installed openplotter on the PI at home about 3 weeks ago. Finding I'm using more and more lower case when two fingered typing. Never worked with linux until I got the Pi, so its a steep learning curve.

that's a good tip on the browsers, I've found Chromium painfully slow.
Reply
#14
Good Morning.

Firefox is sure a lot better than Chromium.

Friday, I deleted the 12c and gpio connections i had made. bet i used never in the one box instead of NEVER. rebooted, installed firefox. Started 12c and tried setting it up again. worked just like your example. works much better in firefox!
still no data.

went down today to see what I could do. data stream coming in from the network via the Actisence NTG-1 as normal.

Got a new button activated in the I2c, rescue. clicked it. now, I have I2C data, but data from the NTG-1 seems to be blocked.  says connecting but doesnt. see next attachment for more detail and screenshots.

.pdf   More I2C issues june 18 .pdf (Size: 447.15 KB / Downloads: 103)

startup /system check is next.
.txt   check june 18.txt (Size: 2.06 KB / Downloads: 82)

sure appears that the I2C conflicts with the NTG-1. no wonder I had issues.
not sure if it's a ver 3.x or not. could not get I2C data last year on ver.2.x.
Reply
#15
Alan

"Friday, I deleted the 12c and gpio connections i had made." - which GPIO connections had you set up?

Please see attached


Attached Files
.pdf   P1.pdf (Size: 395.1 KB / Downloads: 95)
Reply
#16
(2023-06-19, 02:42 AM)amckeown Wrote: Good Morning.

Firefox is sure a lot better than Chromium.

Friday, I deleted the 12c and gpio connections i had made. bet i used never in the one box instead of NEVER. rebooted, installed firefox. Started 12c and tried setting it up again. worked just like your example. works much better in firefox!
still no data.

went down today to see what I could do. data stream coming in from the network via the Actisence NTG-1 as normal.

Got a new button activated in the I2c, rescue. clicked it. now, I have I2C data, but data from the NTG-1 seems to be blocked.  says connecting but doesnt. see next attachment for more detail and screenshots.


startup /system check is next.

sure appears that the I2C conflicts with the NTG-1. no wonder I had issues.
not sure if it's a ver 3.x or not. could not get I2C data last year on ver.2.x.

No gpio connections added yet. planning on putting a small fan in the  pican m enclosure run of gpio, controlled by the Pi. The pi has always overheated in warm to hot weather.
can take it off for now.

The i2c seems to start before the actisense connection.  when I look at the signalk instrument webapp screen, all the network data is not active, yet the I2c shows numbers changing.

the Pi occasionally "locks up", always done that, and I have to remove the power connection. Thats why we get the one opencpn message in the system check file. It starts anyway even with the error message.  (The default OpenCPN connection is missing and is not getting data from Signal K. Please autostart enabled   ↳OpenCPN shortcut is broken, click "Install" in OpenCPN Installer app to
rebuild it.)
probably will get to the boat later today, will let you know what I find.
Thanks very much
Reply
#17
(2023-06-16, 08:21 AM)baltika_no_9 Wrote: Alan

Those screenshots are extremely useful, thank you. They are consistent with what I see which is refreshing (although settings are different of course on my system, the functionality is the same)

What they show is that there is no outstanding request to approve for I2C because you have completed it successfully. The little red square next to Access requests shown on p3 of your document is no longer there on p4. On p5 you see the message Device I2C has been approved too. Incidentally the never/NEVER distinction is crucial, this is linux after all. Lower case 'never' will not be accepted, you have to follow the format shown on the panel which is unambiguously upper case.

So we now know that your issue has nothing to do with the request for approval (although I have a niggling worry that you're saying this need to approve comes back again at some stage?). After pressing Approve on the request in Signal K whether the system declines your input (e.g if you put 'never') or accepts it, there is no message to the user from signal K. The most obvious indicator is whether that red square next to Access requests stays there or disappears. Yours has gone so we're OK. You can also see on the I2C panel on p2 of your document it says at the bottom "The access request no longer exists, press Refresh".  Interestingly you say you pressed Refresh and it came up with a signal K screen. I am baffled by that but it may be a red herring.

Then next steps then are just to try to add one of your sensors. As I said you really want to be sure about what you have. The address of yours are 0x76 so that suggests BMP280 (temperature and pressure only). A final confirmation can be made by looking as the small metal can on the sensor PCB. If it is obviously non-square then it is a BMP280.

What happens when you try these steps next (screenshots in earlier post):

1. Go to Openplotter>I2C and in the Sensors Tab click Add

2. Under Supported sensors click BMP280 and Detected addresses 0x76,  click OK

3. You should now see two lines, one yellow, one white. Left click on the white one and it turns grey, click Edit. Under Signal K key type environment.inside.temperature and hit OK. Now both lines are yellow.

4. Go to Openplotter>Signal K>Data Browser and you see the data for pressure and temperature.

Good luck

Finally, managing signal K in chromium I find to be a nightmare. It painfully slow. I would suggest you consider installing firefox and having a bookmark pointing at localhost:3000/admin

If you want to access  signal K open firefox and click the bookmark rather than going through Openplotter>Signal K.

Success at last I hope.
In the attachment, I have screenshots of everything I did. Did a few checks, then rebooted the Pi.  don't understand why rebooting created both nema and i2c connections. rebooting never did anything like that before.
finally was able to delete the one ttyusb connection,  replaced and rebooted. when I left, everything seemed to be working properly. fingers crossed.
next time im down will run a  system check to see what things are like.

FYI, on a 7" screen, influx db is about unusable, even with tabbing to get to boxes.
Thank you very much for your help.
.pdf   June 19 I2C.pdf (Size: 961.99 KB / Downloads: 113)
Reply
#18
Well I sincerely hope it stays fixed Alan.

I'm a little surprised that you've managed to set your serial port to remember device and it works but let's not poke that one.

Empty alias and data boxes on the serial page is normal I wouldn't expect them to be filled. They're only used once to set up a new serial device.

Best of luck
Reply
#19
(2023-06-13, 11:59 PM)baltika_no_9 Wrote: Hi Alan

I don't understand when you say the I2C page is dead, can you elaborate?

I am using I2C 3.3.12 on a Pi 4 and have just set up a BMP280 as a test and it works fine. I've too many screenshots of the process to fit in one post so first let me try to explain by text:

In a terminal window run the command to find the address of your BMP280:

Code:
i2cdetect -y 1

You should (probably) see a 76 in the output grid which is the typical BMP280 address but it may differ on occasions but it would be uncommon.

Go to Openplotter>I2C and you will see a message at the bottom of the page saying the access request must be aproved (sic) etc

Go to Openplotter>Signal K and log in with the admin credentials. If you haven't already set this up then enable it now and log in.

Under the Security Tab you will see Access Requests at the bottom, click that, click the entry in the Identifier row, select NEVER and Read/Write in the Authentication Timeout and Permissions Respectively. Then Approve. 

Go to Openplotter>I2C and in the Sensors Tab click Add

Under Supported sensors click BMP280 and Detected addresses 0x76 (assuming yours is on that address), click OK

You should now see two lines, one yellow, one white. Left click on the white one and it turns grey, click Edit. Under Signal K key type environment.inside.temperature and hit OK. Now both lines are yellow.

Go to Openplotter>Signal K>Data Browser and you see the data for pressure and temperature.

I'll add a few screenshots in the hope it helps, I think the max is 5 in one post.

Good luck

Hello, I am in the same trouble... the only difference of configuration is that I have two adresses for BME280 : 68 and 76
I do exactly the procedure until all the lines turn yellow but when I check in signal K data browser, I connot see the same result I can see on your screanshot, in the path colomne environnement.inside.temperature doesn't appear ! Instead there is validation.I2C and temperature is not return in the opencpn dashboard

An idea ? Thanks Christophe
Reply
#20
The BME280 cannot have two addresses. The 0x68 is another device. Can you post some screenshots?
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)