This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
date set to Jan 2080 and unable to fix
#1
  • OpenPlotter app version  (2023-08-04-OpenPlotter-v3-Headless-stable-64bit-img)
  • Raspberry Pi model 4 B
    64 bit
  • Connected devices
    Maiana
  • Gl.inet wifi via lan
  • usb hubRii i8s wireless keyboard and mouse pad
  • 32gig thumb drive with opencpn



Hello, after installing open cpn, linking Maiana, and downloading charts I suddenly lost my ability to use the vnc via ras pi wifi connection. i accessed the program through my connected wireless router and rebooted the system several times. the onboard wifi connection began to work again but when I attempted to sync with the internet. I noticed that my open cpn  time was off by many hours and when I looked at the date it was now showing that the month was Jan in 2080. Today was 17nov 2023. I could not access anything to update or repair the program. I verified my servers were all up to date and time then I proceeded with simply updating the program date and time through terminal with     sudo date -s 'Fri Nov 17 23:20:11 PST 2023'      it worked for about 1min than reverted back to the incorrect date. I did this several times with the same result. then I proceeded to install a NTP. again I still had no luck. I am unsure what to do further in order to be able to download charts or update opencpn using the net.

following the directions for gathering debug info from openplotter.....

pi@openplotter:~ $ openplotter-settings
wrong external apps format: unexpected EOF while parsing (<string>, line 0)
wrong external apps format: unexpected EOF while parsing (<string>, line 0)
wrong external apps format: unexpected EOF while parsing (<string>, line 0)

pi@openplotter:~ $ openplotter-serial
wrong external apps format: unexpected EOF while parsing (<string>, line 0)
No module named 'openplotterSdrVhf'
No module named 'openplotterAvnav'
No module named 'openplotterNotifications'
No module named 'openplotterMaiana.serialPorts'
No module named 'openplotterIob'
No module named 'openplotterGpio'
No module named 'openplotterI2c'
No module named 'openplotterPypilot'
No module named 'openplotterNetwork'
No module named 'openplotterDashboards.serialPorts'


Attached Files
.docx   NTP open plotter.docx (Size: 665.27 KB / Downloads: 28)
Reply
#2
You probably are indoors with poor satellite view and no GPS fix. That date is provided by the MAIANA because by default OpenPlotter is configured to take the date from the GPS. Once the GPS is installed on board it will take just some seconds to get a fix and this should be not a problem. If you want to confirm this, disable the signal k plugin in charge of update the system date from the GPS: http://openplotter.local:3000/admin/#/se...ystem-time
Reply
#3
Thank you so much. That fixed it.
Reply
#4
What is the exact value being output? We should block that in set-system-time as invalid.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)