This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Manage palette not available
#1
Hi,
I tried to install a new node in node red. Unfortunately the "Manage palette" is not available in the menu.
A Google search told me, that it could be due to an older version of npm.

I´ve done already an updat with:
sudo apt update
sudo apt upgrade

How do I update npm in Openplotter without causing trouble?
Reply
#2
sudo npm install -g npm@latest
Reply
#3
Hola Sailoog, moltes gràcies!
Unfortunaltely that didn´t help.  There´s a long error message. 

Code:
xx@xx:~ $ sudo npm install -g npm@latest
/usr/lib/node_modules/npm/lib/cli.js:35
    throw err
    ^

TypeError: Class extends value undefined is not a constructor or null
    at Object.<anonymous> (/usr/lib/node_modules/npm/node_modules/fs-minipass/lib/index.js:136:4)
    at Module._compile (node:internal/modules/cjs/loader:1256:14)
    at Module._extensions..js (node:internal/modules/cjs/loader:1310:10)
    at Module.load (node:internal/modules/cjs/loader:1119:32)
    at Module._load (node:internal/modules/cjs/loader:960:12)
    at Module.require (node:internal/modules/cjs/loader:1143:19)
    at require (node:internal/modules/cjs/helpers:121:18)
    at Object.<anonymous> (/usr/lib/node_modules/npm/node_modules/cacache/lib/content/read.js:4:13)
    at Module._compile (node:internal/modules/cjs/loader:1256:14)
    at Module._extensions..js (node:internal/modules/cjs/loader:1310:10)

Node.js v18.17.1
Reply


Forum Jump:


Users browsing this thread: 2 Guest(s)