This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Setting up SignalK Server in BBN
Hi All, 
I'm new to the form and have what is probably a newbie question, so please have patience with me. I've just installed BBN on a Raspberry Pi4, have booted it up and started up SignalK Server. I can't however for the life of me figure out what the default server user ID and password are and when I try to register a new user ID (email and password), and click "register" nothing happens. I have gathered that until I figure out how to log in as an admin into SignalK Server, I won't be able to configure it to see the data coming from an iKommunicate gateway I've installed on my boat. 
Appreciate any help or steer that the wiser folks on this forum may please be able to provide. 
User name: changeme
Pw: changeme
It’s really SignalK question. Not OP question. 
BBN OS just has SignalK installed as is. So there is no admin user
or password set. You do it by logging in for the first time.

‘Sign up’ link has nothing to do with SignalK user or password
It’s a link to sign up to SignalK web site on internet.

I’m not sure you want to call your SignalK admin user ‘changeme’
as the previous poster suggested.
Download BBN Marine OS for raspberry pi

Video of actual installation:

Thanks all. Correct, my question is not about the operating system user name and password, I've defined those. My question is about the SignalK server user name and password. I've tried "changeme" as user name and "changeme" as password, but that didn't work in the SignalK server. I've also tried "user" as user name and "changeme" as password in the SignalK server, that also did not work. I have also followed the link above which suggests:

Remove this section from your settings.json (that is usually located at $HOME/.signalk/settings.json)

"security": {
"strategy": "./tokensecurity"
If your server is started with --securityenabled argument you need to remove that to disable security.

But when I try to use the file browsers in BBN to get to that director, I'm told I don't have permission. Obviously I don't know enough about Linux terminal commands, so started a tutorial on that, but got lost. Sigh. Appreciate any further suggestions!

Forum Jump:

Users browsing this thread: 1 Guest(s)